Jahia Install Forum > MVN issue while...

0 (0 Good)
0 (0 Bad)

MVN issue while creating template module in jahia 7.0

by  vk »  2015/02/05 22:23

Hi,

I encoutered a maven exception while trying to creating a template module from studio in jahia 7.0. Please let me know if there is any setting to fix the SSL issue.

[WARNING] Error reading archetype catalog https://devtools.jahia.com/nexus/content/repositories/jahia-releases/archetype-catalog.xml
org.apache.maven.wagon.TransferFailedException: peer not authenticated
        at org.apache.maven.wagon.shared.http4.AbstractHttpClientWagon.fillInputData(AbstractHttpClientWagon.java:892)
        at org.apache.maven.wagon.StreamWagon.getInputStream(StreamWagon.java:116)
        at org.apache.maven.wagon.StreamWagon.getIfNewer(StreamWagon.java:88)
        at org.apache.maven.wagon.StreamWagon.get(StreamWagon.java:61)
        at org.apache.maven.archetype.source.RemoteCatalogArchetypeDataSource.downloadCatalog(RemoteCatalogArchetypeDataSource.java:119)
        at org.apache.maven.archetype.source.RemoteCatalogArchetypeDataSource.getArchetypeCatalog(RemoteCatalogArchetypeDataSource.java:87)
        at org.apache.maven.archetype.DefaultArchetypeManager.getRemoteCatalog(DefaultArchetypeManager.java:216)

Thank you,

vk

vk
Number of messages  5
Not registered
0 (0 Good)
0 (0 Bad)

Re: MVN issue while creating template module in jahia 7.0

by  shyrkov »  2015/02/09 09:46

Hello,

it could be that the JRE does not automatiically accepts the SSL certificates.

You could try running mvn command with the following options:

-Dmaven.wagon.http.ssl.insecure=true -Dmaven.wagon.http.ssl.allowall=true

or adding the certificate into your JRE.

Kind regards

Sergiy

  • Re: MVN issue while creating template module in jahia 7.0
    2015/02/09 09:46

    shyrkov <p>Hello,</p> <p>it could be that the JRE does not automatiically accepts the SSL certificates.</p> <p>You could try running mvn command with the following options:</p> <pre class="lang-java prettyprint prettyprinted" style=""> <code><span class="pun">-</span><span class="typ">Dmaven</span><span class="pun">.</span><span class="pln">wagon</span><span class="pun">.</span><span class="pln">http</span><span class="pun">.</span><span class="pln">ssl</span><span class="pun">.</span><span class="pln">insecure</span><span class="pun">=</span><span class="kwd">true</span><span class="pln"> </span><span class="pun">-</span><span class="typ">Dmaven</span><span class="pun">.</span><span class="pln">wagon</span><span class="pun">.</span><span class="pln">http</span><span class="pun">.</span><span class="pln">ssl</span><span class="pun">.</span><span class="pln">allowall</span><span class="pun">=</span><span class="kwd">true</span></code></pre> <p>or adding the certificate into your JRE.</p> <p>Kind regards</p> <p>Sergiy</p>

  • Number of messages  407
    Registration date Feb 9, 2015
    0 (0 Good)
    0 (0 Bad)

    Re: Re: MVN issue while creating template module in jahia 7.0

    by  vk »  2015/02/10 21:01

    Thanks Sergiy. The issue is not with the proxy setting of MVN but its an issue on the network. I fixed the issue and MVN is working properly.

    vk

    vk
    Number of messages  5
    Not registered
    Contact
    Share
    Feedback

    Get in touch

    Whether you are a current user or if you are just evaluating Jahia, we are here to help.

    Contact us

    Share this page