Jahia Install Forum > Mac OS 10.6 Install...

0 (0 Good)
0 (0 Bad)

Mac OS 10.6 Install Problems

by  pelorus »  2011/06/07 20:54

Hi,
I've downloaded community edition and tried to run Install.sh however I get JAVA_HOME errors. JAVA_HOME is however set and every other Java app on this Mac finds Java without problems.

Any suggestions?

Thanks
Mike

  (pelorus)

Number of messages  2
Registration date
0 (0 Good)
0 (0 Bad)

Re: Mac OS 10.6 Install Problems

by  dsaulnier »  2011/06/07 20:54

Hello,

Can you confirm that your JAVA_HOME environment variable is bind to a JDK and not a JRE? Jahia needs an application server to run (Tomcat by default), and such software requires a JDK, for example to compile the jsp files.

If this does not solve your problem, can you copy here the errors you get?


Regards,
Damien

Damien Saulnier (dsaulnier)

Number of messages  31
Registration date
0 (0 Good)
0 (0 Bad)

Re: Mac OS 10.6 Install Problems

by  shuber »  2011/06/07 20:54

Hello,

Indeed there seems to be a problem with the scripts under Mac OS X. You can get around this by using the following commands to start Jahia :

cd bin
./startup.sh

After a few seconds, Jahia will become available at the URL :

http://localhost:8080/config

Best regards,
Serge Huber.

Serge Huber (shuber)

Number of messages  271
Registration date
0 (0 Good)
0 (0 Bad)

Re: Mac OS 10.6 Install Problems

by  pelorus »  2011/06/07 20:54

 

This seems to be the case. Serge was precisely right with his solution. The install scripts if invoked from the root directory just throw errors. Starting as Serge suggests overcomes the problem.

I wonder if it's possible to include a MacReadMe.txt in the next distribution to alert users to this workaround? Sometimes when you are assessing multiple systems a problem like this is enough to eliminate the system from consideration.

Thanks for the assistance.

Regards

Mike

shuber wrote:

Hello, 

Indeed there seems to be a problem with the scripts under Mac OS X. You can get around this by using the following commands to start Jahia : 

cd bin

./startup.sh

After a few seconds, Jahia will become available at the URL : 

http://localhost:8080/config

Best regards,

Serge Huber.

  (pelorus)

Number of messages  2
Registration date
0 (0 Good)
0 (0 Bad)

Re: Mac OS 10.6 Install Problems

by  shuber »  2011/06/07 20:54

Thank you for the suggestion Mike. Actually what I did yesterday was update the documentation available here (and linked from the README.txt in the distribution) : http://www.jahia.org/cms/home/Jahiapedi ... figuration

Hopefully this will help others on Mac OS X avoid the trouble you had.

Best Regards,
Serge Huber.

Serge Huber (shuber)

Number of messages  271
Registration date
0 (0 Good)
0 (0 Bad)

Re: Mac OS 10.6 Install Problems

by  mdurepos »  2011/06/07 20:54

I actually had this problem, got beyond it, and ran into another issue myself. After completing step 6 of the configuration wizard, I've had a variety of things happen that stopped progress:

  • A null pointer exception with stack trace printed to the screen
  • A "waiting for shutdown" message that seems to simply time out and provide a button that returns me to the start of configuration.
  • A message that states that the config wizard reported errors - without showing any info about what the errors are.

I've tried configuring the system with both the embedded database and an instance of MySQL running on my machine with no luck (similar results in both cases). I've also tried running with the shipped tomcat install as well as another pre-existing tomcat install after following the directions for "upgrading tomcat".

Also running on OS X 10.6, have tried a variety of JDK and JRE options with the default and most commonly attempted one being version 1.6.

Any help would be greatly appreciated. Please let me know of any extra information I can provide that would be of use.

  (mdurepos)

Number of messages  2
Registration date
0 (0 Good)
0 (0 Bad)

Re: Mac OS 10.6 Install Problems

by  mdurepos »  2011/06/07 20:54

I've actually managed to solve my own problem here after sifting through the logged output in logs/catalina.out.

The problem seemed to be that tomcat was failing to shut down both automatically through the wizard and when I manually ran bin/shutdown.sh. I'm not quite sure why this was the case, but somehow my machine ended up with 3 different JVMs running Tomcat instances. Once I killed all of those remaining instances (ps -e | grep java did the job for finding them) and ran bin/startup.sh once again, then went to http://localhost:8080, I was presented with the new site config page.

Hope this helps anyone who runs into a similar issue. Looking forward to a good test drive now laugh

  (mdurepos)

Number of messages  2
Registration date
0 (0 Good)
0 (0 Bad)

Re: Re: Mac OS 10.6 Install Problems

by  tomarnst »  2011/06/13 07:17

I've actually managed to solve my own problem here after sifting through the logged output in logs/catalina.out.

The problem seemed to be that tomcat was failing to shut down both automatically through the wizard and when I manually ran bin/shutdown.sh. I'm not quite sure why this was the case, but somehow my machine ended up with 3 different JVMs running Tomcat instances. Once I killed all of those remaining instances (ps -e | grep java did the job for finding them) and ran bin/startup.sh once again, then went to http://localhost:8080, I was presented with the new site config page.

Hope this helps anyone who runs into a similar issue. Looking forward to a good test drive now :)


Hi,

 

I think i have the same problem overhere.. I installed 6.5. o.k. but after restart the system i get a tomcat error 404.... and can't get to jahia anymore.

Can you be more specific how you closesd and found the JVMs ?

Thanks

  (tomarnst)

Number of messages  9
Registration date
Contact
Share
Feedback

Get in touch

Whether you are a current user or if you are just evaluating Jahia, we are here to help.

Contact us

Share this page