Jahia Install Forum > Jahia install for...

0 (0 Good)
0 (0 Bad)

Jahia install for Eclipse

by  snite »  2014/10/29 10:50

Hello everyone,

I try to install Jahia on my local computer to integrate it whith Eclipse.

First, I went to this URL : http://subversion.jahia.org/svn/jahia_community_dev/releases/JAHIA_7_0_0_0/

Then I checkout this repository on my local computer.

Finally I launch the following terminal instruction command : ./install.sh -P installer

I get the following error :

[INFO] Scanning for projects...
Downloading: https://devtools.jahia.com/nexus/content/groups/public/org/jahia/modules/jaxrs-osgi-extender-bom/1.0.0-SNAPSHOT/maven-metadata.xml
Downloading: https://devtools.jahia.com/nexus/content/groups/public/org/jahia/modules/jaxrs-osgi-extender-bom/1.0.0-SNAPSHOT/jaxrs-osgi-extender-bom-1.0.0-SNAPSHOT.pom
[ERROR] The build could not read 1 project -> [Help 1]
[ERROR]   
[ERROR]   The project org.jahia.server:jahia-war:7.0.0.0 (/home/snite/workspace/JAHIA_7_0_0_0/jahia/war/pom.xml) has 1 error
[ERROR]     Non-resolvable import POM: Could not find artifact org.jahia.modules:jaxrs-osgi-extender-bom:pom:1.0.0-SNAPSHOT in jahia-public (https://devtools.jahia.com/nexus/content/groups/public) @ org.jahia.server:jahia-war:[unknown-version], /home/snite/workspace/JAHIA_7_0_0_0/jahia/war/pom.xml, line 93, column 25 -> [Help 2]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
[ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException

Trying whith the -U option (./install.sh -P installer -U) :

[INFO] Scanning for projects...
Downloading: https://devtools.jahia.com/nexus/content/groups/public/org/jahia/modules/jaxrs-osgi-extender-bom/1.0.0-SNAPSHOT/maven-metadata.xml
Downloading: https://devtools.jahia.com/nexus/content/groups/public/org/jahia/modules/jaxrs-osgi-extender-bom/1.0.0-SNAPSHOT/jaxrs-osgi-extender-bom-1.0.0-SNAPSHOT.pom
[ERROR] The build could not read 1 project -> [Help 1]
[ERROR]   
[ERROR]   The project org.jahia.server:jahia-war:7.0.0.0 (/home/snite/workspace/JAHIA_7_0_0_0/jahia/war/pom.xml) has 1 error
[ERROR]     Non-resolvable import POM: Could not find artifact org.jahia.modules:jaxrs-osgi-extender-bom:pom:1.0.0-SNAPSHOT in jahia-public (https://devtools.jahia.com/nexus/content/groups/public) @ line 93, column 25 -> [Help 2]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
[ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException

Here is the result of svn --version output :

svn, version 1.8.8 (r1568071)
   compiled Aug 13 2014, 17:12:39 on x86_64-pc-linux-gnu

Copyright (C) 2013 The Apache Software Foundation.
This software consists of contributions made by many people;
see the NOTICE file for more information.
Subversion is open source software, see http://subversion.apache.org/

The following repository access (RA) modules are available:

* ra_svn : Module for accessing a repository using the svn network protocol.
  - with Cyrus SASL authentication
  - handles 'svn' scheme
* ra_local : Module for accessing a repository on local disk.
  - handles 'file' scheme
* ra_serf : Module for accessing a repository via WebDAV protocol using serf.
  - using serf 1.3.3
  - handles 'http' scheme
  - handles 'https' scheme

Here is the result of mvn --version output :

Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da; 2013-02-19 14:51:28+0100)
Maven home: /opt/apache-maven-3.0.5
Java version: 1.7.0_71, vendor: Oracle Corporation
Java home: /opt/jdk1.7.0_71/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "3.13.0-37-generic", arch: "amd64", family: "unix"

Best regards,

Snite

 

snite
Number of messages  3
Not registered
0 (0 Good)
0 (0 Bad)

Re : Jahia install for Eclipse

by  glucazeau »  2014/10/29 11:07

Hello,

it seems there is a problem with this dependency, please switch the jaxrs-osgi-extender-bom version to 2.0.0 in jahia/war/pom.xml and let me know if it fixes your issue.

Regards,

Guillaume

  • Re : Jahia install for Eclipse
    2014/10/29 11:07

    glucazeau <p>Hello,</p> <p>it seems there is a problem with this dependency, please switch the jaxrs-osgi-extender-bom version to 2.0.0 in jahia/war/pom.xml and let me know if it fixes your issue.</p> <p>Regards,</p> <p>Guillaume</p>

  • Number of messages  95
    Registration date Oct 29, 2014
    0 (0 Good)
    0 (0 Bad)

    Re : Re : Jahia install for Eclipse

    by  snite »  2014/10/29 11:18

    Hello,

    it seems there is a problem with this dependency, please switch the jaxrs-osgi-extender-bom version to 2.0.0 in jahia/war/pom.xml and let me know if it fixes your issue.

    Regards,

    Guillaume

    Old line :

        <dependencyManagement>
            <dependencies>
                <dependency>
                    <groupId>org.jahia.modules</groupId>
                    <artifactId>jaxrs-osgi-extender-bom</artifactId>
                    <version>1.0.0-SNAPSHOT</version>
                    <type>pom</type>
                    <scope>import</scope>
                </dependency>
            </dependencies>
        </dependencyManagement>

    New line :

        <dependencyManagement>
            <dependencies>
                <dependency>
                    <groupId>org.jahia.modules</groupId>
                    <artifactId>jaxrs-osgi-extender-bom</artifactId>
                    <version>2.0.0-SNAPSHOT</version>
                    <type>pom</type>
                    <scope>import</scope>
                </dependency>
            </dependencies>
        </dependencyManagement>

    This did not fix the problem, but :

        <dependencyManagement>
            <dependencies>
                <dependency>
                    <groupId>org.jahia.modules</groupId>
                    <artifactId>jaxrs-osgi-extender-bom</artifactId>
                    <version>2.0.0</version>
                    <type>pom</type>
                    <scope>import</scope>
                </dependency>
            </dependencies>
        </dependencyManagement>

    My project is downloading and building, I'll come back on this topic if any errors occurs, thanks for your help !

     

     

    snite
    Number of messages  3
    Not registered
    0 (0 Good)
    0 (0 Bad)

    Re : Jahia install for Eclipse

    by  snite »  2014/10/29 11:45

    Build success.

    I get an error when importing projects to eclipse.

    I did Import "existing maven project" then the following error appear : No marketplace entries found to handle jahia-maven-plugin:4.0:copy-templates in Eclipse.  Please see Help for more information.

    I put an image to let you know the exact error message and on the left projects which are imported (are them all good ?).

    Regards,

    Snite

    snite
    Number of messages  3
    Not registered
    0 (0 Good)
    0 (0 Bad)

    Re : Re : Jahia install for Eclipse

    by  glucazeau »  2014/10/29 16:43

    I get this message too, it should work if you click on "Finish", this plugin is just not handled directly by Eclipse.

  • Re : Re : Jahia install for Eclipse
    2014/10/29 16:43

    glucazeau <p>I get this message too, it should work if you click on &quot;Finish&quot;, this plugin is just not handled directly by Eclipse.</p>

  • Number of messages  95
    Registration date Oct 29, 2014
    Contact
    Share
    Feedback

    Get in touch

    Whether you are a current user or if you are just evaluating Jahia, we are here to help.

    Contact us

    Share this page