Jahia Install Forum > Jahia 6 with hsqldb

0 (0 Good)
0 (0 Bad)

Jahia 6 with hsqldb

by  cn.schacht »  2011/06/07 20:51

Hi there! Just tried to install a freshly downloaded Jahia V6 CE (r25203) with standard options on Windows Vista. At the point of configuring the DB I chose hypersonic embedded (as the default). The step returned a "Error while connecting to the database:socket creation error".

There is no additional error in the tomcat console, HSQLDB seems to have started okay as well:

[Server@1c85444]: Database [index=0, id=0, db=file:D:\Projekte\Jahia\webapps\con
fig\WEB-INF\dbdata\hsqldbjahia, alias=hsqldbjahia] opened sucessfully in 618 ms.

[Server@1c85444]: Startup sequence completed in 644 ms.
[Server@1c85444]: 2009-04-26 16:00:29.438 HSQLDB server 1.8.0 is online
[Server@1c85444]: To close normally, connect and execute SHUTDOWN SQL
[Server@1c85444]: From command line, use [Ctrl]+[C] to abort abruptly

Any ideas?

Thanks
Christian

 

  (cn.schacht)

Number of messages  6
Registration date
0 (0 Good)
0 (0 Bad)

Re: Jahia 6 with hsqldb

by  pap@commaro.com »  2011/06/07 20:51

Hello Christian,

I tried it at home on my PC with Windows Vista Ultimate installed and when using "HSQL database engine (embedded)" I have got no error and everything installed fine. 

However when I chose the "HSQL database engine (stand alone)" then I get the "Error while connecting to the database:socket creation error". This second possibility is only to be used with JEE application servers - not Tomcat. 

So I assume that you mixed it up and used the stand alone instead of the embedded HSQL database.

Regards,
Benjamin

Benjamin Papez (pap@commaro.com)

Number of messages  220
Registration date
0 (0 Good)
0 (0 Bad)

Re: Jahia 6 with hsqldb

by  cn.schacht »  2011/06/07 20:51

 

Hi Benjamin,

thanks a lot for your reply! 

I fact I did try to install with the "embedded" option and I checked if there where any errors during startup of either tomcat or hsqldb. 

I'm using the same version of Vista btw and JDK 6_13. I tried to run the install with Admin rights and Firewall down but the install behaved exactly the same.

Which Version of Jahia did You use?

Regards

Christian

pap@commaro.com wrote:

I tried it at home on my PC with Windows Vista Ultimate installed and when using "HSQL database engine (embedded)" I have got no error and everything installed fine. 

 

However when I chose the "HSQL database engine (stand alone)" then I get the "Error while connecting to the database:socket creation error". This second possibility is only to be used with JEE application servers - not Tomcat. 

 

So I assume that you mixed it up and used the stand alone instead of the embedded HSQL database.

 

Regards,

Benjamin

  (cn.schacht)

Number of messages  6
Registration date
0 (0 Good)
0 (0 Bad)

Re: Jahia 6 with hsqldb

by  pap@commaro.com »  2011/06/07 20:51

Hi Christian,

I used the downloaded jahia_v6_CommunityEdition_r25203 and also with JDK 6_13. So looks like we used the same environments, but I installed it without Administrator privileges and the Firewall turned on.

Only when using the HSQL standalone option I get the socket creation error and also only in the UI. There is no hint about it in the log, where the HSQL DB seems to startup fine.

Could you check if there is already a context.xml file created in webapps/ROOT/META-INF ?

For the embedded version the settings in there should be (among others):

driverClassName="org.hsqldb.jdbcDriver" 
url="jdbc:hsqldb:hsql://localhost/hsqldbjahia" 
accessToUnderlyingConnectionAllowed="true" 

Regards,
Benjamin

Benjamin Papez (pap@commaro.com)

Number of messages  220
Registration date
0 (0 Good)
0 (0 Bad)

Re: Jahia 6 with hsqldb

by  cn.schacht »  2011/06/07 20:51

I have tried to download again, extract everything to the install folder and start the install from scratch but with no changes. I thought file permissions might be wrong but I checked that too. So I'm a bit puzzled.

After the install I don't find a folder webapps/ROOT, under webapps there are only folders for "config", "host-manager" and "manager".

Logs under [jahia]/logs don't show any interesting messages. Under webapps\config\WEB-INF\dbdata there is a hsqldbjahia.lck file and the log-file contains:

CREATE USER SA PASSWORD "" ADMIN
/*C1*/SET SCHEMA PUBLIC
CONNECT USER SA
DISCONNECT

this looks like the connect to the DB might actually have worked.

Anything else to check? Your help is really appreciated!

Best regards
Christian

  (cn.schacht)

Number of messages  6
Registration date
0 (0 Good)
0 (0 Bad)

Re: Jahia 6 with hsqldb

by  pap@commaro.com »  2011/06/07 20:51

Hello again,

I am also quite puzzled. A possibility would be that localhost is no longer mapped to 127.0.0.0

Coud you please open C:\Windows\System32\drivers\etc\hosts and check if the following lines are there (uncommented):

127.0.0.1 localhost
::1 localhost

Where you can select the database in the Jahia installation wizzard you could also simply overwrite the connection string for the embedded HSQLDB and write 127.0.0.1 instead of localhost.

If this also does not work, then try adding the following in bin\catalina.bat in line 54 at the end of setting CATALINA_OPTS after -verbose:gc also set
-Djava.net.preferIPv4Stack=true
and start the installation process again.

Regards,
Benjamin

Benjamin Papez (pap@commaro.com)

Number of messages  220
Registration date
0 (0 Good)
0 (0 Bad)

Re: Jahia 6 with hsqldb

by  cn.schacht »  2011/06/07 20:51

Yes, that was it laugh

I mapped 127.0.0.1 to localhost and now everything is fine!

Thanks a lot!

Best regards
Christian

  (cn.schacht)

Number of messages  6
Registration date
Contact
Share
Feedback

Get in touch

Whether you are a current user or if you are just evaluating Jahia, we are here to help.

Contact us

Share this page