Jahia Install Forum > Error when upgrading...

0 (0 Good)
0 (0 Bad)

Error when upgrading with Fix Package 6.6.2.7 to 7.0.0.0

by  Bruno »  2015/01/06 16:55

After the fix , following error occurs :

Thanks for an hint ....

2015-01-06 17:49:57,044: WARN  [localhost-startStop-1] org.jahia.bin.listeners.JahiaContextLoaderListener:
java.lang.NullPointerException
    at java.io.Reader.<init>(Reader.java:61)
    at java.io.InputStreamReader.<init>(InputStreamReader.java:96)
    at org.apache.commons.io.IOUtils.copy(IOUtils.java:1906)
    at org.apache.commons.io.IOUtils.toString(IOUtils.java:778)
    at org.apache.commons.io.IOUtils.toString(IOUtils.java:759)
    at org.jahia.bin.listeners.JahiaContextLoaderListener.startupWithTrust(JahiaContextLoaderListener.java:423)
    at org.jahia.bin.listeners.JahiaContextLoaderListener.contextInitialized(JahiaContextLoaderListener.java:186)
    at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4973)
    at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5467)
    at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
    at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901)
    at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877)
    at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:632)
    at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1229)
    at org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1875)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:439)
    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
    at java.util.concurrent.FutureTask.run(FutureTask.java:138)
    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
    at java.lang.Thread.run(Thread.java:662)
2015-01-06 17:49:57,591: INFO  [localhost-startStop-1] org.jahia.bin.listeners.JahiaContextLoaderListener: Starting up Digital Factory, please wait...
2015-01-06 17:49:57,750: INFO  [localhost-startStop-1] org.jahia.bin.listeners.JahiaContextLoaderListener: Start initializing Spring root application context
2015-01-06 17:49:57,751: INFO  [localhost-startStop-1] org.apache.pluto.driver.PortalStartupListener: Starting up Pluto Portal Driver. . .
2015-01-06 17:50:00,285: ERROR [localhost-startStop-1] org.springframework.web.context.ContextLoader: Context initialization failed
java.lang.NoClassDefFoundError: org/jahia/services/templates/TemplatePackageApplicationContextLoader$ContextInitializedEvent
    at java.lang.Class.getDeclaredMethods0(Native Method)
    at java.lang.Class.privateGetDeclaredMethods(Class.java:2436)
    at java.lang.Class.getDeclaredMethods(Class.java:1793)
    at org.springframework.util.ReflectionUtils.doWithMethods(ReflectionUtils.java:474)
    at org.springframework.util.ReflectionUtils.doWithMethods(ReflectionUtils.java:458)
    at org.springframework.util.ReflectionUtils.getUniqueDeclaredMethods(ReflectionUtils.java:518)
    at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.getTypeForFactoryMethod(AbstractAutowireCapableBeanFactory.java:639)
    at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.predictBeanType(AbstractAutowireCapableBeanFactory.java:575)
    at org.springframework.beans.factory.support.AbstractBeanFactory.isFactoryBean(AbstractBeanFactory.java:1350)
    at org.springframework.beans.factory.support.DefaultListableBeanFactory.doGetBeanNamesForType(DefaultListableBeanFactory.java:355)
    at org.springframework.beans.factory.support.DefaultListableBeanFactory.getBeanNamesForType(DefaultListableBeanFactory.java:326)
    at org.springframework.beans.factory.support.DefaultListableBeanFactory.getBeansOfType(DefaultListableBeanFactory.java:434)
    at org.springframework.context.support.AbstractApplicationContext.invokeBeanFactoryPostProcessors(AbstractApplicationContext.java:624)
    at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:461)
    at org.springframework.web.context.ContextLoader.configureAndRefreshWebApplicationContext(ContextLoader.java:410)
    at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:306)
    at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:112)
    at org.apache.pluto.driver.PortalStartupListener.contextInitialized(PortalStartupListener.java:108)
    at org.jahia.bin.listeners.JahiaContextLoaderListener.contextInitialized(JahiaContextLoaderListener.java:227)
    at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4973)
    at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5467)
    at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
    at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901)
    at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877)
    at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:632)
    at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1229)
    at org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1875)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:439)
    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
    at java.util.concurrent.FutureTask.run(FutureTask.java:138)
    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
    at java.lang.Thread.run(Thread.java:662)
Caused by: java.lang.ClassNotFoundException: org.jahia.services.templates.TemplatePackageApplicationContextLoader$ContextInitializedEvent
    at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1718)
    at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1569)
    ... 33 more
2015-01-06 17:50:00,304: INFO  [localhost-startStop-1] org.jahia.bin.listeners.JahiaContextLoaderListener: Stopping OSGi platform service
2015-01-06 17:50:00,321: ERROR [localhost-startStop-1] org.jahia.bin.listeners.JahiaContextLoaderListener: Error stopping OSGi platform service. Cause: null
java.lang.NullPointerException
    at org.jahia.bin.listeners.JahiaContextLoaderListener.contextDestroyed(JahiaContextLoaderListener.java:380)
    at org.apache.catalina.core.StandardContext.listenerStop(StandardContext.java:5014)
    at org.apache.catalina.core.StandardContext.stopInternal(StandardContext.java:5659)
    at org.apache.catalina.util.LifecycleBase.stop(LifecycleBase.java:232)
    at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:160)
    at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901)
    at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877)
    at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:632)
    at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1229)
    at org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1875)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:439)
    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
    at java.util.concurrent.FutureTask.run(FutureTask.java:138)
    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
    at java.lang.Thread.run(Thread.java:662)
2015-01-06 17:50:00,421: INFO  [localhost-startStop-1] org.jahia.bin.listeners.JahiaContextLoaderListener: OSGi platform service stopped in 18 ms
2015-01-06 17:50:00,421: INFO  [localhost-startStop-1] org.jahia.bin.listeners.JahiaContextLoaderListener: Shutting down Spring root application context
2015-01-06 17:50:00,421: INFO  [localhost-startStop-1] org.apache.pluto.driver.PortalStartupListener: Shutting down Pluto Portal Driver...
2015-01-06 17:50:00,422: INFO  [localhost-startStop-1] org.apache.pluto.driver.PortalStartupListener: Shutting down Pluto Portal Driver...
2015-01-06 17:50:00,422: INFO  [localhost-startStop-1] org.apache.pluto.driver.PortalStartupListener: ********** Pluto Portal Driver Shut Down **********

Bruno
Number of messages  2
Not registered
0 (0 Good)
0 (0 Bad)

Re: Error when upgrading with Fix Package 6.6.2.7 to 7.0.0.0

by  shyrkov »  2015/01/06 17:09

Hello Bruno,

the class org.jahia.services.templates.TemplatePackageApplicationContextLoader$ContextInitializedEvent indeed does no longer exist in DF 7.0 (Caused by: java.lang.ClassNotFoundException: ...).

Could you check, if you have "old" Spring files, located for example uneder <jahia-web-app-dir>/WEB-INF/etc/spring or some "old" jahia-*.jar files under <jahia-web-app-dir>/WEB-INF/lib?

Kind regards

Sergiy

  • Re: Error when upgrading with Fix Package 6.6.2.7 to 7.0.0.0
    2015/01/06 17:09

    shyrkov <p>Hello Bruno,</p> <p>the class org.jahia.services.templates.TemplatePackageApplicationContextLoader$ContextInitializedEvent indeed does no longer exist in DF 7.0 (Caused by: java.lang.ClassNotFoundException: ...).</p> <p>Could you check, if you have &quot;old&quot; Spring files, located for example uneder &lt;jahia-web-app-dir&gt;/WEB-INF/etc/spring or some &quot;old&quot; jahia-*.jar files under &lt;jahia-web-app-dir&gt;/WEB-INF/lib?</p> <p>Kind regards</p> <p>Sergiy</p>

  • Number of messages  407
    Registration date Jan 6, 2015
    0 (0 Good)
    0 (0 Bad)

    Re : Re: Error when upgrading with Fix Package 6.6.2.7 to 7.0.0.0

    by  Bruno »  2015/01/06 17:39

    Hello Bruno,

    the class org.jahia.services.templates.TemplatePackageApplicationContextLoader$ContextInitializedEvent indeed does no longer exist in DF 7.0 (Caused by: java.lang.ClassNotFoundException: ...).

    Could you check, if you have "old" Spring files, located for example uneder <jahia-web-app-dir>/WEB-INF/etc/spring or some "old" jahia-*.jar files under <jahia-web-app-dir>/WEB-INF/lib?

    Kind regards

    Sergiy

     

    Hello Sergiy
    ,

    I've checked there is nothing in .../etc/spring but a lot of jar under lib, some are my custom module (prefix aelb-) , how can I choose the jar to be deleted ??

     318 jar in total...

    Best Regards

    Bruno

     

    Bruno
    Number of messages  2
    Not registered
    0 (0 Good)
    0 (0 Bad)

    Re : Re : Re: Error when upgrading with Fix Package 6.6.2.7 to 7.0.0.0

    by  glucazeau »  2015/01/08 15:54

    Hello Bruno,

    first, check that all the jars starting with "jahia-" are with the correct version (7.0.0.0, not 6.6 jars)

    Regards,

    Guillaume

  • Re : Re : Re: Error when upgrading with Fix Package 6.6.2.7 to 7.0.0.0
    2015/01/08 15:54

    glucazeau <p>Hello Bruno,</p> <p>first, check that all the jars starting with &quot;jahia-&quot; are with the correct version (7.0.0.0, not 6.6 jars)</p> <p>Regards,</p> <p>Guillaume</p>

  • Number of messages  93
    Registration date Jan 8, 2015
    0 (0 Good)
    0 (0 Bad)

    Re: Re : Re: Error when upgrading with Fix Package 6.6.2.7 to 7.0.0.0

    by  shyrkov »  2015/01/09 09:29

    Hello Bruno,

    Digital Factory 7 uses OSGi framework for modules, i.e. in 7.0.0.0 no JARs or classes are extracted from modules (so the content of WEB-INF/lib remains the same as during the installation).

    In order to check, which JARs are "native" in WEB-INF/lib and which come from your modules, you could perhaps install separately a DF 7.0.0.0 instance using the installer and compare the content of WEB-INF/lib with your migrated environment.

     

    For technical details and OSGi concept for modules in DF 7.0 you could check our documentatio section at: http://www.jahia.com/documentation-and-downloads/developers-documentation

     

    Kind regards

    Sergiy

  • Re: Re : Re: Error when upgrading with Fix Package 6.6.2.7 to 7.0.0.0
    2015/01/09 09:29

    shyrkov <p>Hello Bruno,</p> <p>Digital Factory 7 uses OSGi framework for modules, i.e. in 7.0.0.0 no JARs or classes are extracted from modules (so the content of WEB-INF/lib remains the same as during the installation).</p> <p>In order to check, which JARs are &quot;native&quot; in WEB-INF/lib and which come from your modules, you could perhaps install separately a DF 7.0.0.0 instance using the installer and compare the content of WEB-INF/lib with your migrated environment.</p> <p>&nbsp;</p> <p>For technical details and OSGi concept for modules in DF 7.0 you could check our documentatio section at: <a href="http://www.jahia.com/documentation-and-downloads/developers-documentation">http://www.jahia.com/documentation-and-downloads/developers-documentation</a></p> <p>&nbsp;</p> <p>Kind regards</p> <p>Sergiy</p>

  • Number of messages  407
    Registration date Jan 9, 2015
    0 (0 Good)
    0 (0 Bad)

    Re : Re : Re : Re: Error when upgrading with Fix Package 6.6.2.7 to 7.0.0.0

    by  brunoseznec »  2015/01/09 10:03

    Hi Guillaume & Sergly

    I 've installed a new VM with CentOS 6.3. 

    in WEB-INF/lib all the jahia jar are in "-7" version, I've moved my specific jar temporarely.

    almost the same error.

    Best Regards

    Bruno

     

  • Re : Re : Re : Re: Error when upgrading with Fix Package 6.6.2.7 to 7.0.0.0
    2015/01/09 10:03

    brunoseznec <p>Hi Guillaume &amp; Sergly</p> <p>I &#39;ve installed a new VM with&nbsp;CentOS 6.3.&nbsp;</p> <p>in WEB-INF/lib all the jahia jar are in &quot;-7&quot; version, I&#39;ve moved my specific jar temporarely.</p> <p>almost the same error.</p> <p>Best Regards</p> <p>Bruno</p> <p>&nbsp;</p>

  • Number of messages  19
    Registration date Jan 9, 2015
    0 (0 Good)
    0 (0 Bad)

    Re : Re : Re : Re : Re: Error when upgrading with Fix Package 6.6.2.7 to 7.0.0.0

    by  shyrkov »  2015/01/09 10:27

    Hello Bruno,

    do you perhaps have in one of your JAR files, which you copy to WEB-INF/lib somewhere an applicationcontext-*.xml file inside (under org/jahia/defaults/config/... or org/jahia/config/...)?

    Kind regards

    Sergiy

  • Re : Re : Re : Re : Re: Error when upgrading with Fix Package 6.6.2.7 to 7.0.0.0
    2015/01/09 10:27

    shyrkov <p>Hello Bruno,</p> <p>do you perhaps have in one of your JAR files, which you copy to WEB-INF/lib somewhere an applicationcontext-*.xml file inside (under org/jahia/defaults/config/... or org/jahia/config/...)?</p> <p>Kind regards</p> <p>Sergiy</p>

  • Number of messages  407
    Registration date Jan 9, 2015
    0 (0 Good)
    0 (0 Bad)

    Rendering works but login fails

    by  brunoseznec »  2015/01/13 10:53

    Hi all,

    Finally, I realize that I have used a Fix from the community version on an Enterprise version

    So I replay the full process (on Win8 , JDK6)

    6.6.1.7 -> 6.6.2.0 -> >>> 7 fixes 6.6.2.7 -> Enterprise package update. 7.0.0.0

    With this path no issue with old jahia 6 lib that stays after the update.

    But I remarks a warning on tag lib and there no webpage rendering and login, jahia tools seems to work.

    Below some extract from the logs :

    Tomorrow I will try this path on Centos.

    >>>>

    INFO: At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.

    For a ACME web page rendering :
     
     ERROR [http-bio-8080-exec-2] org.jahia.bin.errors.ErrorLoggingFilter:
    java.lang.NullPointerException
        at org.jahia.services.render.filter.TemplateAttributesFilter.prepare(TemplateAttributesFilter.java:127)
        at org.jahia.services.render.filter.RenderChain.doFilter(RenderChain.java:181)
        at org.jahia.services.render.RenderService.render(RenderService.java:225)
        at org.jahia.bin.Render.doGet(Render.java:279)
        at org.jahia.bin.Render.handleRequest(Render.java:835)
        
        On a login page :
        
        ERROR [http-bio-8080-exec-10] org.jahia.bin.errors.ErrorLoggingFilter: L''exꤵtion du filtre (Filter) a lanc页ne exception. Error message: org.jahia.params.valves.LoginEngineAuthValveImpl.isAccountLocked(Lorg/jahia/services/usermanager/JahiaUser;)Z
    java.lang.NoSuchMethodError: org.jahia.params.valves.LoginEngineAuthValveImpl.isAccountLocked(Lorg/jahia/services/usermanager/JahiaUser;)Z
        at org.jahia.params.valves.LoginEngineAuthValveImpl.invoke(LoginEngineAuthValveImpl.java:150)
        at org.jahia.pipelines.impl.GenericPipeline.invokeNext(GenericPipeline.java:247)
        at org.jahia.params.valves.TokenAuthValveImpl.invoke(TokenAuthValveImpl.java:109)
        at org.jahia.pipelines.impl.GenericPipeline.invokeNext(GenericPipeline.java:247)
        at org.jahia.params.valves.HttpBasicAuthValveImpl.invoke(HttpBasicAuthValveImpl.java:138)
        at org.jahia.pipelines.impl.GenericPipeline.invokeNext(GenericPipeline.java:247)
        at org.jahia.params.valves.SsoValve.invoke(SsoValve.java:100)

    Here is the error message , when trying to log

    error details are shown in development mode. To switch it off, change the operatingMode in jahia.properties.
                    
    Error: org.jahia.params.valves.LoginEngineAuthValveImpl.isAccountLocked(Lorg/jahia/services/usermanager/JahiaUser;)Zjava.lang.NoSuchMethodError: org.jahia.params.valves.LoginEngineAuthValveImpl.isAccountLocked(Lorg/jahia/services/usermanager/JahiaUser;)Z

     

    >>

    Thanks for some hints, is this Forum relevant as it is an Enterprise version ?

    Rgds

    Bruno

     

     

     

  • Rendering works but login fails
    2015/01/18 18:36

    brunoseznec <p>Hi all,</p> <p>Finally, I realize that I have used a Fix from the community version on an Enterprise version</p> <p>So I replay the full process (on Win8 , JDK6)</p> <p>6.6.1.7 -&gt; 6.6.2.0 -&gt; &gt;&gt;&gt; 7 fixes 6.6.2.7 -&gt; Enterprise package update. 7.0.0.0</p> <p>With this path no issue with old jahia 6 lib that stays after the update.</p> <p>But I remarks a warning on tag lib and there no webpage rendering and login, jahia tools seems to work.</p> <p>Below some extract from the logs :</p> <p>Tomorrow I will try this path on Centos.</p> <p>&gt;&gt;&gt;&gt;</p> <p>INFO: At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.</p> <p>For a ACME web page rendering :<br /> &nbsp;<br /> &nbsp;ERROR [http-bio-8080-exec-2] org.jahia.bin.errors.ErrorLoggingFilter:<br /> java.lang.NullPointerException<br /> &nbsp;&nbsp; &nbsp;at org.jahia.services.render.filter.TemplateAttributesFilter.prepare(TemplateAttributesFilter.java:127)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.services.render.filter.RenderChain.doFilter(RenderChain.java:181)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.services.render.RenderService.render(RenderService.java:225)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.bin.Render.doGet(Render.java:279)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.bin.Render.handleRequest(Render.java:835)<br /> &nbsp;&nbsp; &nbsp;<br /> &nbsp;&nbsp; &nbsp;On a login page :<br /> &nbsp;&nbsp; &nbsp;<br /> &nbsp;&nbsp; &nbsp;ERROR [http-bio-8080-exec-10] org.jahia.bin.errors.ErrorLoggingFilter: L&#39;&#39;exꤵtion du filtre (Filter) a lanc页ne exception. Error message: org.jahia.params.valves.LoginEngineAuthValveImpl.isAccountLocked(Lorg/jahia/services/usermanager/JahiaUser;)Z<br /> java.lang.NoSuchMethodError: org.jahia.params.valves.LoginEngineAuthValveImpl.isAccountLocked(Lorg/jahia/services/usermanager/JahiaUser;)Z<br /> &nbsp;&nbsp; &nbsp;at org.jahia.params.valves.LoginEngineAuthValveImpl.invoke(LoginEngineAuthValveImpl.java:150)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.pipelines.impl.GenericPipeline.invokeNext(GenericPipeline.java:247)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.params.valves.TokenAuthValveImpl.invoke(TokenAuthValveImpl.java:109)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.pipelines.impl.GenericPipeline.invokeNext(GenericPipeline.java:247)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.params.valves.HttpBasicAuthValveImpl.invoke(HttpBasicAuthValveImpl.java:138)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.pipelines.impl.GenericPipeline.invokeNext(GenericPipeline.java:247)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.params.valves.SsoValve.invoke(SsoValve.java:100)</p> <p>Here is the error message , when trying to log</p> <p>error details are shown in development mode. To switch it off, change the operatingMode in jahia.properties.<br /> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;<br /> Error: org.jahia.params.valves.LoginEngineAuthValveImpl.isAccountLocked(Lorg/jahia/services/usermanager/JahiaUser;)Zjava.lang.NoSuchMethodError: org.jahia.params.valves.LoginEngineAuthValveImpl.isAccountLocked(Lorg/jahia/services/usermanager/JahiaUser;)Z</p> <p>&nbsp;</p> <p>&gt;&gt;</p> <p>Thanks for some hints, is this Forum relevant as it is an Enterprise version ?</p> <p>Rgds</p> <p>Bruno</p> <p>&nbsp;</p> <p>&nbsp;</p> <p>&nbsp;</p>

  • Number of messages  19
    Registration date Jan 13, 2015
    0 (0 Good)
    0 (0 Bad)

    Re : Rendering works but login fails

    by  brunoseznec »  2015/01/20 16:26

    Hi all,

    Finally, I realize that I have used a Fix from the community version on an Enterprise version

    So I replay the full process (on Win8 , JDK6)

    6.6.1.7 -> 6.6.2.0 -> >>> 7 fixes 6.6.2.7 -> Enterprise package update. 7.0.0.0

    With this path no issue with old jahia 6 lib that stays after the update.

    But I remarks a warning on tag lib and there no webpage rendering and login, jahia tools seems to work.

    Below some extract from the logs :

    Tomorrow I will try this path on Centos.

    >>>>

    INFO: At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.

    For a ACME web page rendering :
     
     ERROR [http-bio-8080-exec-2] org.jahia.bin.errors.ErrorLoggingFilter:
    java.lang.NullPointerException
        at org.jahia.services.render.filter.TemplateAttributesFilter.prepare(TemplateAttributesFilter.java:127)
        at org.jahia.services.render.filter.RenderChain.doFilter(RenderChain.java:181)
        at org.jahia.services.render.RenderService.render(RenderService.java:225)
        at org.jahia.bin.Render.doGet(Render.java:279)
        at org.jahia.bin.Render.handleRequest(Render.java:835)
        
        On a login page :
        
        ERROR [http-bio-8080-exec-10] org.jahia.bin.errors.ErrorLoggingFilter: L''exꤵtion du filtre (Filter) a lanc页ne exception. Error message: org.jahia.params.valves.LoginEngineAuthValveImpl.isAccountLocked(Lorg/jahia/services/usermanager/JahiaUser;)Z
    java.lang.NoSuchMethodError: org.jahia.params.valves.LoginEngineAuthValveImpl.isAccountLocked(Lorg/jahia/services/usermanager/JahiaUser;)Z
        at org.jahia.params.valves.LoginEngineAuthValveImpl.invoke(LoginEngineAuthValveImpl.java:150)
        at org.jahia.pipelines.impl.GenericPipeline.invokeNext(GenericPipeline.java:247)
        at org.jahia.params.valves.TokenAuthValveImpl.invoke(TokenAuthValveImpl.java:109)
        at org.jahia.pipelines.impl.GenericPipeline.invokeNext(GenericPipeline.java:247)
        at org.jahia.params.valves.HttpBasicAuthValveImpl.invoke(HttpBasicAuthValveImpl.java:138)
        at org.jahia.pipelines.impl.GenericPipeline.invokeNext(GenericPipeline.java:247)
        at org.jahia.params.valves.SsoValve.invoke(SsoValve.java:100)

    Here is the error message , when trying to log

    error details are shown in development mode. To switch it off, change the operatingMode in jahia.properties.
                    
    Error: org.jahia.params.valves.LoginEngineAuthValveImpl.isAccountLocked(Lorg/jahia/services/usermanager/JahiaUser;)Zjava.lang.NoSuchMethodError: org.jahia.params.valves.LoginEngineAuthValveImpl.isAccountLocked(Lorg/jahia/services/usermanager/JahiaUser;)Z

     

    >>

    Thanks for some hints, is this Forum relevant as it is an Enterprise version ?

    Rgds

    Bruno

    Do you know, if there is an issue with the SQL upgrade scripts ::

    2015-01-20 14:53:40,349: INFO  [localhost-startStop-1] org.jahia.tools.patches.SqlPatcher: Found 6 SQL patches to execute:
    ServletContext resource [/WEB-INF/var/patches/sql/derby/jbpm-schema.sql]ServletContext resource [/WEB-INF/var/patches/sql/derby/jahia-nodetypes-provider.sql]ServletContext resource [/WEB-INF/var/patches/sql/derby/jahia-external-provider-schema.sql]ServletContext resource [/WEB-INF/var/patches/sql/derby/jackrabbit-schema.sql]ServletContext resource [/WEB-INF/var/patches/sql/derby/drop-jbpm4-schema.sql]ServletContext resource [/WEB-INF/var/patches/sql/derby/jgroups-schema.sql]

    .....///// .....

    Caused by: java.sql.SQLException: Column 'ID'  cannot accept a NULL value.
        at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
        at org.apache.derby.impl.jdbc.SQLExceptionFactory40.wrapArgsForTransportAcrossDRDA(Unknown Source)
        ... 104 more

    Thanks

    Bruno

     

     

     

     

     

     

  • Re : Rendering works but login fails
    2015/01/20 16:26

    brunoseznec <blockquote> <p>Hi all,</p> <p>Finally, I realize that I have used a Fix from the community version on an Enterprise version</p> <p>So I replay the full process (on Win8 , JDK6)</p> <p>6.6.1.7 -&gt; 6.6.2.0 -&gt; &gt;&gt;&gt; 7 fixes 6.6.2.7 -&gt; Enterprise package update. 7.0.0.0</p> <p>With this path no issue with old jahia 6 lib that stays after the update.</p> <p>But I remarks a warning on tag lib and there no webpage rendering and login, jahia tools seems to work.</p> <p>Below some extract from the logs :</p> <p>Tomorrow I will try this path on Centos.</p> <p>&gt;&gt;&gt;&gt;</p> <p>INFO: At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.</p> <p>For a ACME web page rendering :<br /> &nbsp;<br /> &nbsp;ERROR [http-bio-8080-exec-2] org.jahia.bin.errors.ErrorLoggingFilter:<br /> java.lang.NullPointerException<br /> &nbsp;&nbsp; &nbsp;at org.jahia.services.render.filter.TemplateAttributesFilter.prepare(TemplateAttributesFilter.java:127)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.services.render.filter.RenderChain.doFilter(RenderChain.java:181)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.services.render.RenderService.render(RenderService.java:225)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.bin.Render.doGet(Render.java:279)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.bin.Render.handleRequest(Render.java:835)<br /> &nbsp;&nbsp; &nbsp;<br /> &nbsp;&nbsp; &nbsp;On a login page :<br /> &nbsp;&nbsp; &nbsp;<br /> &nbsp;&nbsp; &nbsp;ERROR [http-bio-8080-exec-10] org.jahia.bin.errors.ErrorLoggingFilter: L&#39;&#39;exꤵtion du filtre (Filter) a lanc页ne exception. Error message: org.jahia.params.valves.LoginEngineAuthValveImpl.isAccountLocked(Lorg/jahia/services/usermanager/JahiaUser;)Z<br /> java.lang.NoSuchMethodError: org.jahia.params.valves.LoginEngineAuthValveImpl.isAccountLocked(Lorg/jahia/services/usermanager/JahiaUser;)Z<br /> &nbsp;&nbsp; &nbsp;at org.jahia.params.valves.LoginEngineAuthValveImpl.invoke(LoginEngineAuthValveImpl.java:150)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.pipelines.impl.GenericPipeline.invokeNext(GenericPipeline.java:247)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.params.valves.TokenAuthValveImpl.invoke(TokenAuthValveImpl.java:109)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.pipelines.impl.GenericPipeline.invokeNext(GenericPipeline.java:247)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.params.valves.HttpBasicAuthValveImpl.invoke(HttpBasicAuthValveImpl.java:138)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.pipelines.impl.GenericPipeline.invokeNext(GenericPipeline.java:247)<br /> &nbsp;&nbsp; &nbsp;at org.jahia.params.valves.SsoValve.invoke(SsoValve.java:100)</p> <p>Here is the error message , when trying to log</p> <p>error details are shown in development mode. To switch it off, change the operatingMode in jahia.properties.<br /> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;<br /> Error: org.jahia.params.valves.LoginEngineAuthValveImpl.isAccountLocked(Lorg/jahia/services/usermanager/JahiaUser;)Zjava.lang.NoSuchMethodError: org.jahia.params.valves.LoginEngineAuthValveImpl.isAccountLocked(Lorg/jahia/services/usermanager/JahiaUser;)Z</p> <p>&nbsp;</p> <p>&gt;&gt;</p> <p>Thanks for some hints, is this Forum relevant as it is an Enterprise version ?</p> <p>Rgds</p> <p>Bruno</p> </blockquote> <p>Do you know, if there is an issue with the SQL upgrade scripts ::</p> <p>2015-01-20 14:53:40,349: INFO&nbsp; [localhost-startStop-1] org.jahia.tools.patches.SqlPatcher: Found 6 SQL patches to execute:<br /> ServletContext resource [/WEB-INF/var/patches/sql/derby/jbpm-schema.sql]ServletContext resource [/WEB-INF/var/patches/sql/derby/jahia-nodetypes-provider.sql]ServletContext resource [/WEB-INF/var/patches/sql/derby/jahia-external-provider-schema.sql]ServletContext resource [/WEB-INF/var/patches/sql/derby/jackrabbit-schema.sql]ServletContext resource [/WEB-INF/var/patches/sql/derby/drop-jbpm4-schema.sql]ServletContext resource [/WEB-INF/var/patches/sql/derby/jgroups-schema.sql]</p> <p>.....///// .....</p> <p>Caused by: java.sql.SQLException: Column &#39;ID&#39;&nbsp; cannot accept a NULL value.<br /> &nbsp;&nbsp; &nbsp;at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)<br /> &nbsp;&nbsp; &nbsp;at org.apache.derby.impl.jdbc.SQLExceptionFactory40.wrapArgsForTransportAcrossDRDA(Unknown Source)<br /> &nbsp;&nbsp; &nbsp;... 104 more</p> <p>Thanks</p> <p>Bruno</p> <blockquote> <p>&nbsp;</p> <p>&nbsp;</p> <p>&nbsp;</p> </blockquote> <p>&nbsp;</p> <p>&nbsp;</p> <p>&nbsp;</p>

  • Number of messages  19
    Registration date Jan 20, 2015
    0 (0 Good)
    0 (0 Bad)

    Re : Rendering works but login fails

    by  glucazeau »  2015/01/21 13:12

    Thanks for some hints, is this Forum relevant as it is an Enterprise version ?

    Hello Bruno,

    Just a quick reply to this, if you have a support contract please use this tool to submit a ticket, this will be more efficient and easy to track the issue and help you: http://support.jahia.com/

    Regards,

    Guillaume

     

     

  • Re : Rendering works but login fails
    2015/01/21 13:12

    glucazeau <blockquote>Thanks for some hints, is this Forum relevant as it is an Enterprise version ?</blockquote> <p>Hello Bruno,</p> <p>Just a quick reply to this, if you have a support contract please use this tool to submit a ticket, this will be more efficient and easy to track the issue and help you: http://support.jahia.com/</p> <p>Regards,</p> <p>Guillaume</p> <p>&nbsp;</p> <p>&nbsp;</p>

  • Number of messages  93
    Registration date Jan 21, 2015
    Contact
    Share
    Feedback

    Get in touch

    Whether you are a current user or if you are just evaluating Jahia, we are here to help.

    Contact us

    Share this page