Jahia Install Forum > error 101 after...

0 (0 Good)
0 (0 Bad)

error 101 after a "successful" install find mvn.bat in directory "."

by  edaubias »  2015/01/23 09:31

Hello,

I am trying to install jahia entreprise edition (but I also tried the community, and the demo version) but It seems no matter how i run the installation I don't get the login page when i run http://localhost:8080/.

I tried with 2 different JDK (jdk1.7.0_75 and jdk1.8.0_25) because the community install display a warning about the version i was using (1.8).

I also got a java IOException: cannot find mvn.bat in directory "."

Maybe it's the source of the problem.

Any ideas? 

 

Thanks

  (edaubias)

Number of messages  8
Registration date
0 (0 Good)
0 (0 Bad)

Re: error 101 after a "successful" install find mvn.bat in directory "."

by  brunoseznec »  2015/01/23 14:07

Hi,

May be you can try to define M2_HOME as an env variable pointing to your maven installation.

HTH

Bruno

  (brunoseznec)

Number of messages  19
Registration date
0 (0 Good)
0 (0 Bad)

Re : Re: error 101 after a "successful" install find mvn.bat in directory "."

by  edaubias »  2015/01/23 15:26

Thanks for helping !

I tried to get a Maven installation from http://maven.apache.org/download.cgi, then set a M2_HOME env variable and add it to the Path, then proceed to launch the digitalFactory.bat but didn't work.

 
Isn't Maven supposed to be installed with jahia?

 

  (edaubias)

Number of messages  8
Registration date
0 (0 Good)
0 (0 Bad)

Re : Re : Re: error 101 after a "successful" install find mvn.bat in directory "."

by  brunoseznec »  2015/01/26 08:42

Hi,

I don't think Maven is installed with Jahia. What is the precise error message, is you port 8080 alrready open by another application??

Regards

Bruno

  (brunoseznec)

Number of messages  19
Registration date
0 (0 Good)
0 (0 Bad)

Re : Re : Re : Re: error 101 after a "successful" install find mvn.bat in directory "."

by  edaubias »  2015/01/26 09:53

Hi,

I don't think there is any application using 8080 port. I checked with a netstats -ano.

 

Here is the error message while launching the startdigitalfactory.bat:


Your Server has generated an error. Please review the details below for additional information: 

Error: java.io.IOException: Cannot run program "mvn.bat" (in directory "."): CreateProcess error=2, Le fichier spécifié est introuvable

 

The last part means: the file was not found.

This error is followed by a long stacktrace

and a few things include this line :

 M2_HOME : C:\Users\edaubias\.m2\repository\org\apache\maven

I checked and there is a maven folder indeed.

I also tried to get the last maven installation and set M2_HOME on it.

Here is the log of the error if your curious of anything else : http://pastebin.com/riDtt1hg

 

Regards

  (edaubias)

Number of messages  8
Registration date
0 (0 Good)
0 (0 Bad)

Re : Re : Re : Re : Re: error 101 after a "successful" install find mvn.bat in directory "."

by  brunoseznec »  2015/01/26 10:35

Just to try I have change my M2_HOME to an unknown folder.

DF started with the error message on mvn.bat but it doesn't prevent all the registration of the Osgi modules.

I think you must read other error messages see jahia.log file.

Regards

Bruno

  (brunoseznec)

Number of messages  19
Registration date
0 (0 Good)
0 (0 Bad)

Re : Re : Re : Re : Re : Re: error 101 after a "successful" install find mvn.bat in directory "."

by  edaubias »  2015/01/26 11:03

I got no other error messages

In the jahia log, all i got is this error, 2 warning messages and a ton of INFO log.

The two warnings are : 

org.hibernate.id.UUIDHexGenerator: HHH000409: Using org.hibernate.id.UUIDHexGenerator which does not generate IETF RFC 4122 compliant UUID values; consider using org.hibernate.id.UUIDGenerator instead

org.jahia.ajax.gwt.commons.server.ChannelHolder: Unable to unregister JMX beans for the JGroups channel atmosphere-jahia

I don't think it is related..

edit: I can run a Grails Web App on the port 8080 so i don't think the port are unavailable/blocked

Regards

  (edaubias)

Number of messages  8
Registration date
0 (0 Good)
0 (0 Bad)

Re : Re : Re : Re : Re : Re : Re: error 101 after a "successful" install find mvn.bat in directory "."

by  brunoseznec »  2015/01/26 13:08

I got no other error messages

In the jahia log, all i got is this error, 2 warning messages and a ton of INFO log.

The two warnings are : 

org.hibernate.id.UUIDHexGenerator: HHH000409: Using org.hibernate.id.UUIDHexGenerator which does not generate IETF RFC 4122 compliant UUID values; consider using org.hibernate.id.UUIDGenerator instead

org.jahia.ajax.gwt.commons.server.ChannelHolder: Unable to unregister JMX beans for the JGroups channel atmosphere-jahia

I don't think it is related..

edit: I can run a Grails Web App on the port 8080 so i don't think the port are unavailable/blocked

Regards

==

I have the same warning on Hibernate .

you must have something like that :

--------------------------------------------------------------------------------------------------
  D E V E L O P M E N T   M O D E   A C T I V E

  In development mode, Digital Factory will allow JSPs to be modified, modules to be re-deployed and
  other modifications to happen immediately, but these DO have a performance impact. It is strongly
  recommended to switch to production mode when running performance tests or going live. The
  setting to change modes is called operatingMode in the jahia.properties configuration file.
--------------------------------------------------------------------------------------------------
  Modules:
      Started: 77
--------------------------------------------------------------------------------------------------
  Digital Factory 7.0.0.2 [Elektra] - Enterprise Distribution - Build 51016.3163 is now ready. Initialization completed in 130 seconds

...

 

 

 

  (brunoseznec)

Number of messages  19
Registration date
0 (0 Good)
0 (0 Bad)

Re : Re : Re : Re : Re : Re : Re : Re: error 101 after a "successful" install find mvn.bat in directory "."

by  edaubias »  2015/01/26 13:17

I have the same. The only difference is that I got 78 modules and i am in 7.0.0.3

  (edaubias)

Number of messages  8
Registration date
0 (0 Good)
0 (0 Bad)

Re : Re : Re : Re : Re : Re : Re : Re : Re: error 101 after a "successful" install find mvn.bat in directory "."

by  edaubias »  2015/01/26 14:06

Maven is finally working when i add the bin repertory directly to the path and not using a M2_HOME var.

Nonetheless I can't have Jahia running after the launch of the tomcat server

  (edaubias)

Number of messages  8
Registration date
Contact
Share
Feedback

Get in touch

Whether you are a current user or if you are just evaluating Jahia, we are here to help.

Contact us

Share this page