Jahia Install Forum > DigitalFactory-EnterpriseDistr...

0 (0 Good)
0 (0 Bad)

DigitalFactory-EnterpriseDistribution-7.1.0.0-r52740.3425 - Fail to start Workspace Factory module

by  samuelb »  2015/08/05 08:45

Hello,

I'm having erros while trying to start the Workspace Factory 2.0.0 module on the DigitalFactory-EnterpriseDistribution-7.1.0.0-r52740.3425.

I installed the bundle in console mode on an 64bit Ubuntu Server 14 using default parameters and built-in tools (tomcat, Postgre, etc.).

First issue (workaround found)

I first got this error in a stacktrace while activating Workspace Factory 2.0.0 : 

Unresolved constraint in bundle workspace-factory [137]: Unable to resolve 137.1: missing requirement [137.1] osgi.wiring.package; (&(osgi.wiring.package=org.jahia.modules.gateway)(version>=2.0.0)(!(version>=3.0.0)))

I solved this issue by downgrading Jahia Gateway from 3.0.0 to 2.0.1 AND undeploy Jahia Gateway 3.0.0 AND restarting the server (else the same error ccur again, even if Jahia Gateway 3.0.0 is not running).

Second issue (to solve)

With Jahia Gateway in version 2.0.1 I get another error  while activating Workspace Factory 2.0.0 : 

Unresolved constraint in bundle workspace-factory [137]: Unable to resolve 137.1: missing requirement [137.1] osgi.wiring.package; (&(osgi.wiring.package=org.jahia.modules.sociallib)(version>=2.0.0)(!(version>=3.0.0))) [caused by: Unable to resolve 133.1: missing requirement [133.1] osgi.wiring.package; (osgi.wiring.package=org.jahia.services.usermanager.jcr)]

I then looked at the unstarted Jahia Social Module and tried to start it alone, I got with no surprise the second part of the last error :

Unresolved constraint in bundle social [133]: Unable to resolve 133.1: missing requirement [133.1] osgi.wiring.package; (osgi.wiring.package=org.jahia.services.usermanager.jcr)

I could not found any workaround for this error, all user/jcr related modules are installed and active : 

  • Jahia JCR Remoting connector 1.0.0,
  • Jahia RESTful JCR Access 2.1.1,
  • Jahia Users and Groups Bridge Provider 1.0.0
  • Jahia External Provider Users and Groups 1.0.0
  • Portal factory - user portal 2.0.0
  • Jahia User Dashboards 7.1.0
  • Jahia User Registration 2.0.3
  • Jahia User Profile 7.1.0

Finally, I'd like to mention a probably related warning I get in console logs while logging : WARN  [JCRSiteNode] - Couldn't find module 'social' which is a direct or transitive dependency of the site 'systemsite'.

Question

How can I solve the Jahia Social Module missing requirement in order to finally get the Workflow Factory module running ?

Thank you for your help.

  • DigitalFactory-EnterpriseDistribution-7.1.0.0-r52740.3425 - Fail to start Workspace Factory module
    2015/08/05 08:46

    samuelb <p>Hello,</p> <p>I&#39;m having erros while trying to start the Workspace Factory 2.0.0 module on the&nbsp;DigitalFactory-EnterpriseDistribution-7.1.0.0-r52740.3425.</p> <p>I installed the bundle in console mode on an 64bit Ubuntu Server 14 using default parameters and built-in tools (tomcat, Postgre, etc.).</p> <p><strong>First issue (workaround found)</strong></p> <p>I first got this error in a stacktrace while activating Workspace Factory 2.0.0 :&nbsp;</p> <pre style="padding: 7.5px; font-family: Monaco, Menlo, Consolas, 'Courier New', monospace; font-size: 11px; border-radius: 3px; margin-top: 0px; margin-bottom: 8px; line-height: 16px; word-break: break-all; border: 1px solid rgba(0, 0, 0, 0.14902);"> Unresolved constraint in bundle workspace-factory [137]: Unable to resolve 137.1: missing requirement [137.1] osgi.wiring.package; (&amp;(osgi.wiring.package=org.jahia.modules.gateway)(version&gt;=2.0.0)(!(version&gt;=3.0.0)))</pre> <p>I solved this issue by downgrading&nbsp;Jahia Gateway from 3.0.0 to 2.0.1 AND undeploy&nbsp;<span style="line-height: 20.7999992370605px;">Jahia Gateway 3.0.0</span> AND restarting the server (else the same error ccur again, even if<span style="line-height: 20.7999992370605px;">&nbsp;</span><span style="line-height: 20.7999992370605px;">Jahia Gateway 3.0.0 is not running</span>).</p> <p><strong>Second issue (to solve)</strong></p> <p>With&nbsp;<span style="line-height: 20.7999992370605px;">Jahia Gateway in version 2.0.1 I get another error &nbsp;while activating Workspace Factory 2.0.0 :&nbsp;</span></p> <pre style="padding: 7.5px; font-family: Monaco, Menlo, Consolas, 'Courier New', monospace; font-size: 11px; border-radius: 3px; margin-top: 0px; margin-bottom: 8px; line-height: 16px; word-break: break-all; border: 1px solid rgba(0, 0, 0, 0.14902);"> Unresolved constraint in bundle workspace-factory [137]: Unable to resolve 137.1: missing requirement [137.1] osgi.wiring.package; (&amp;(osgi.wiring.package=org.jahia.modules.sociallib)(version&gt;=2.0.0)(!(version&gt;=3.0.0))) [caused by: Unable to resolve 133.1: missing requirement [133.1] osgi.wiring.package; (osgi.wiring.package=org.jahia.services.usermanager.jcr)]</pre> <p>I then looked at the unstarted&nbsp;Jahia Social Module and tried to start it alone, I got with no surprise the second part of the last error :</p> <pre style="padding: 7.5px; font-family: Monaco, Menlo, Consolas, 'Courier New', monospace; font-size: 11px; border-radius: 3px; margin-top: 0px; margin-bottom: 8px; line-height: 16px; word-break: break-all; border: 1px solid rgba(0, 0, 0, 0.14902);"> Unresolved constraint in bundle social [133]: Unable to resolve 133.1: missing requirement [133.1] osgi.wiring.package; (osgi.wiring.package=org.jahia.services.usermanager.jcr)</pre> <p>I could not found any workaround for this error, all user/jcr related modules are installed and active&nbsp;:&nbsp;</p> <ul> <li>Jahia JCR Remoting connector 1.0.0,</li> <li>Jahia RESTful JCR Access 2.1.1,</li> <li>Jahia Users and Groups Bridge Provider 1.0.0</li> <li>Jahia External Provider Users and Groups 1.0.0</li> <li>Portal factory - user portal 2.0.0</li> <li>Jahia User Dashboards 7.1.0</li> <li>Jahia User Registration 2.0.3</li> <li>Jahia User Profile 7.1.0</li> </ul> <p>Finally, I&#39;d like to mention a probably&nbsp;related warning I get in console logs while logging :&nbsp;WARN &nbsp;[JCRSiteNode] - Couldn&#39;t find module &#39;social&#39; which is a direct or transitive dependency of the site &#39;systemsite&#39;.</p> <p><strong>Question</strong></p> <p>How can I solve the&nbsp;<span style="line-height: 20.7999992370605px;">Jahia Social Module missing </span>requirement <span style="line-height: 20.7999992370605px;">in order to finally get the Workflow Factory module running&nbsp;?</span></p> <p>Thank you for your help.</p>

  • Number of messages  1
    Registration date Aug 5, 2015
    Contact
    Share
    Feedback

    Get in touch

    Whether you are a current user or if you are just evaluating Jahia, we are here to help.

    Contact us

    Share this page