Jahia DX > Deploy Templates...

0 (0 Good)
0 (0 Bad)

Deploy Templates in Studio Disabled

by  colinf »  2011/06/07 18:06

Hi,

I have been playing around with the templates in Jahia 6.5 Beta, and am getting there slowly.

I have copied and modified (or massacred) the Web Blue template, and got it to my liking.

But now, when I make changes to the template in Studio (or any other template for that matter), I can't redeploy it... The "Deploy templates" button is disabled.

Any idea on why or how to re-enable it?

Regards
Colin

  (colinf)

Number of messages  5
Registration date
0 (0 Good)
0 (0 Bad)

Re: Deploy Templates in Studio Disabled

by  shuber »  2011/06/07 18:06

Do you have a web site to deploy them to ? If so, try to go back to edit mode and then back in studio mode.

Regards,
Serge Huber.

Serge Huber (shuber)

Number of messages  271
Registration date
0 (0 Good)
0 (0 Bad)

Re: Deploy Templates in Studio Disabled

by  colinf »  2011/06/07 18:07

Hi Serge,

Thanks for your reply, just answering your questions below...

I do have a website to deploy them to. I also have gone out to edit mode, then back to studio (and to contribute mode, flushed cache, logged out and back in, restarted the server, all several times) and all to no avail.

I have also tried creating a new website based on the same template, and this has picked up the changes to the template... however the original website still does not pick up the changes to the template...

So I have one template, and somehow two versions of it are in use at the same time.

Is there a way to change the template set once you have created the site... I went looking to try and change it to something else, then change it back, but I could not find an option for this either (perhaps it does not exist?).

Regards
Colin

  (colinf)

Number of messages  5
Registration date
0 (0 Good)
0 (0 Bad)

Re: Deploy Templates in Studio Disabled

by  shuber »  2011/06/07 18:07

Hi Colin,

Which beta are you using ? I know there were some issues with BETA2.

Maybe you'd like to try with a nightly build ? We are currently stabilizing the software and have fixed a lot of bugs. You can find them here : http://www.jahia.org/cms/home/download/NightlyBuilds

Best regards,
Serge Huber.

Serge Huber (shuber)

Number of messages  271
Registration date
0 (0 Good)
0 (0 Bad)

Re: Deploy Templates in Studio Disabled

by  colinf »  2011/06/07 18:07

Hi Serge,

I was using Beta 3.

I have now downloaded Jahia_xCM_v6.5-SNAPSHOT_r38066 (a recent nightly build) and that seems to be better, I have not played with it a lot yet, but I seem to be able to deploy my template sets now, so thanks for that.

I did find something strange, not sure if it was in the previous beta I was running, if you create a new template set, and give it a name, e.g. "My Template Set", it creates the "my-template-set" directory and uses it. But if you duplicate a template set, it just uses the name you give it (spaces and all), but does not seem to refer to that directory, it seems to keep referring back to the original template set directory that you duplicated... no worries for me, as (once you know what to do (and that is not saying that I do... not by a long stretch :-) )) it seems pretty easy making a new template and copying bits out of the example templates and into the files in the new template directory.

I shall keep playing at it over the next couple of days, and see what happens.

One question I still do have... is choosing a template set for a site a one time thing? Can you change template sets after the site is created?

Thanks
Colin

  (colinf)

Number of messages  5
Registration date
0 (0 Good)
0 (0 Bad)

Re: Deploy Templates in Studio Disabled

by  colinf »  2011/06/07 18:07

I am not sure how I do it, but I have broken it again...

Can't redeploy my template set... happens with a few modify in studio, edit, modify in studio steps...

It seems Jahia looses track of the templates in use and does not allow me to redeploy (the item is disabled, I have also had it show in the list of where to deploy, only one of two sites that are definitely using a template set).

Is there any behind the scenes way to reset this?

Currently I am just mucking around, so I can go and delete my site, make a new one, and I can play with the template sets in Studio again for a little while.

Regards
Colin

  (colinf)

Number of messages  5
Registration date
0 (0 Good)
0 (0 Bad)

Re: Deploy Templates in Studio Disabled

by  tyurk »  2011/06/07 18:07

Colin,

My experience has been that some changes to the template set seem to "break it" temporarily and the virtual site then "loses" its template set and reverts to templates-web or templates-system (can't remember which). To answer your question, choosing template sets is a once-at-creation thing. As a result, this reversion breaks the site. To address this issue, I generally do all my testing on one instance recreating sites as often as I break the template set and then export the template set to .zip and import it into my live server, run the update and with any luck, don't bust the live site... That being said, I haven't played with the more recent betas and nightlies all that much so this behaviour may be fixed or modified since.

Cheers,

Denis

  (tyurk)

Number of messages  38
Registration date
Contact
Share
Feedback

Get in touch

Whether you are a current user or if you are just evaluating Jahia, we are here to help.

Contact us

Share this page