Jahia DX > active directory...

0 (0 Good)
0 (0 Bad)

active directory integration

by  lutfu »  2011/07/01 07:23

I have problem about Jahia and active directory configuration.

**** First problem I configured users-ldap xml file It's ok but can't get all of the users. Some of the users comes.

The configuration for users-ldap is like below

<bean parent="JahiaUserManagerLDAPProvider">
        <property name="ldapProperties">
            <map>
                <entry key="url" value="ldap://127.0.0.1:389/"/>
                <entry key="public.bind.dn" value="cn=administrator,cn=Users,dc=DOMAIN,dc=COM"/>
                <entry key="public.bind.password" value="password"/>
                <entry key="uid.search.name" value="dc=DOMAIN,dc=COM"/>
                <entry key="uid.search.countlimit" value="3000"/>
                <entry key="uid.search.objectclass" value="user"/>
                <entry key="uid.search.attribute" value="cn"/>
            </map>
        </property>
    </bean>

***** The second problem is I can't get acrive directory groups.

My configuration for groups-ldap.xml file is like below

 

<bean parent="JahiaGroupManagerLDAPProvider">
        <property name="ldapProperties">
            <map>
                <entry key="url" value="ldap://127.0.0.1:389/"/>
                <entry key="public.bind.dn" value="cn=administrator,cn=Users,dc=DOMAIN,dc=COM"/>
                <entry key="public.bind.password" value="password"/>
                <entry key="search.attribute" value="cn"/>
                <entry key="search.name" value="dc=DOMAIN,dc=COM"/>
                <entry key="search.countlimit" value="3000"/>
                <entry key="search.objectclass" value="group"/>
                <entry key="search.wildcards.attributes" value="cn,description,uniqueMember"/>
                            
                
            </map>
        </property>
    </bean>

Can you help what I am doing wrong to get active directory groups. How the correct configuration must be?

Thank you in advance.

 

 

 

  • active directory integration
    2011/07/01 07:23

    lutfu <p> I have problem about Jahia and active directory configuration.</p> <p> **** First problem I configured users-ldap xml file It&#39;s ok but can&#39;t get all of the users. Some of the users comes.</p> <p> The configuration for users-ldap is like below</p> <p> &lt;bean parent=&quot;JahiaUserManagerLDAPProvider&quot;&gt;<br /> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;property name=&quot;ldapProperties&quot;&gt;<br /> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;map&gt;<br /> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;entry key=&quot;url&quot; value=&quot;ldap://127.0.0.1:389/&quot;/&gt;<br /> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;entry key=&quot;public.bind.dn&quot; value=&quot;cn=administrator,cn=Users,dc=DOMAIN,dc=COM&quot;/&gt;<br /> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;entry key=&quot;public.bind.password&quot; value=&quot;password&quot;/&gt;<br /> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;entry key=&quot;uid.search.name&quot; value=&quot;dc=DOMAIN,dc=COM&quot;/&gt;<br /> &nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&lt;entry key=&quot;uid.search.countlimit&quot; value=&quot;3000&quot;/&gt;<br /> &nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&lt;entry key=&quot;uid.search.objectclass&quot; value=&quot;user&quot;/&gt;<br /> &nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&lt;entry key=&quot;uid.search.attribute&quot; value=&quot;cn&quot;/&gt;<br /> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/map&gt;<br /> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/property&gt;<br /> &nbsp;&nbsp;&nbsp; &lt;/bean&gt;</p> <p> ***** The second problem is I can&#39;t get acrive directory groups.</p> <p> My configuration for groups-ldap.xml file is like below</p> <p> &nbsp;</p> <p> &lt;bean parent=&quot;JahiaGroupManagerLDAPProvider&quot;&gt;<br /> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;property name=&quot;ldapProperties&quot;&gt;<br /> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;map&gt;<br /> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;entry key=&quot;url&quot; value=&quot;ldap://127.0.0.1:389/&quot;/&gt;<br /> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;entry key=&quot;public.bind.dn&quot; value=&quot;cn=administrator,cn=Users,dc=DOMAIN,dc=COM&quot;/&gt;<br /> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;entry key=&quot;public.bind.password&quot; value=&quot;password&quot;/&gt;<br /> &nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&lt;entry key=&quot;search.attribute&quot; value=&quot;cn&quot;/&gt;<br /> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;entry key=&quot;search.name&quot; value=&quot;dc=DOMAIN,dc=COM&quot;/&gt;<br /> &nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&lt;entry key=&quot;search.countlimit&quot; value=&quot;3000&quot;/&gt;<br /> &nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&lt;entry key=&quot;search.objectclass&quot; value=&quot;group&quot;/&gt;<br /> &nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&lt;entry key=&quot;search.wildcards.attributes&quot; value=&quot;cn,description,uniqueMember&quot;/&gt;<br /> &nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;<br /> &nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;<br /> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/map&gt;<br /> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/property&gt;<br /> &nbsp;&nbsp;&nbsp; &lt;/bean&gt;</p> <p> Can you help what I am doing wrong to get active directory groups. How the correct configuration must be?</p> <p> Thank you in advance.</p> <p> &nbsp;</p> <p> &nbsp;</p> <p> &nbsp;</p>

  • Number of messages  4
    Registration date Jul 1, 2011
    Contact
    Share
    Feedback

    Get in touch

    Whether you are a current user or if you are just evaluating Jahia, we are here to help.

    Contact us

    Share this page