Jahia Template Forum > Jahia 6 - Templates...

0 (0 Good)
0 (0 Bad)

Jahia 6 - Templates Deployment

by  cflond »  2011/06/07 19:55

Hi,

I have followed the official Jahia tutorial to realize my first template (http://www.jahia.org/cms/op/edit/lang/e ... Modularity).

First, I have a question about the directory of the .jsp file. Where do I have to put the home.jsp file ? It's not specified in the doc ! So I put it in : my-custom-templates\src\main\webapp, is it right ?

Secondly, I try to deploy my template with Maven Install in Eclipse ... Everything looks to be ok :

Console :
[code:3o5t1i51]#91;INFO
  • Jahia 6 - Templates Deployment
    2011/06/07 19:55

    cflond Hi,<br/><br/>I have followed the official Jahia tutorial to realize my first template (<!-- m --><a class="postlink" href="http://www.jahia.org/cms/op/edit/lang/en/home/jahiapedia/Template_Developer_Guide/Template_Modularity">http://www.jahia.org/cms/op/edit/lang/e ... Modularity</a><!-- m -->).<br/><br/>First, I have a question about the directory of the .jsp file. Where do I have to put the home.jsp file ? It's not specified in the doc ! So I put it in : my-custom-templates\src\main\webapp, is it right ?<br/><br/>Secondly, I try to deploy my template with Maven Install in Eclipse ... Everything looks to be ok :<br/><br/>Console :<br/>[code:3o5t1i51]#91;INFO

  • Number of messages  42
    Registration date Jun 7, 2011
    0 (0 Good)
    0 (0 Bad)

    Re: Jahia 6 - Templates Deployment

    by  mesdocs »  2011/06/07 19:55

    Hello,

    Home.jsp :
    It's ok to put it in src\main\webapp.

    Deployment :
    Do you have install war:exploded jahia:deploy in your External Tool configuration ?

    If so, maven should deploy your templates to [b:1v632kwv]c:/jahia6ee[/b:1v632kwv]/webapps/Root/templates as described in your settings.xml file.

    Which settings.xml file does maven use (maven2/conf or home/.m2) ?


    Mesdocs
  • Re: Jahia 6 - Templates Deployment
    2011/06/07 19:55

    mesdocs Hello,<br/><br/>Home.jsp : <br/>It's ok to put it in src\main\webapp.<br/><br/>Deployment : <br/>Do you have install war:exploded jahia:deploy in your External Tool configuration ?<br/><br/>If so, maven should deploy your templates to [b:1v632kwv]c:/jahia6ee[/b:1v632kwv]/webapps/Root/templates as described in your settings.xml file.<br/><br/>Which settings.xml file does maven use (maven2/conf or home/.m2) ?<br/><br/><br/>Mesdocs

  • Number of messages  53
    Registration date Jun 7, 2011
    0 (0 Good)
    0 (0 Bad)

    Re: Jahia 6 - Templates Deployment

    by  cflond »  2011/06/07 19:55

    Hi,

    I tried to configure Maven as External Tools for Eclipse without success. But I use the Run as gt; Maven Install in Eclipse to
  • Re: Jahia 6 - Templates Deployment
    2011/06/07 19:55

    cflond Hi,<br/><br/>I tried to configure Maven as External Tools for Eclipse without success. But I use the Run as gt; Maven Install in Eclipse to

  • Number of messages  42
    Registration date Jun 7, 2011
    0 (0 Good)
    0 (0 Bad)

    Re: Jahia 6 - Templates Deployment

    by  Alexis_ »  2011/06/07 19:55

    Hi,

    I have another problem !
    When i tried to execute :
    [code:8r96xgc6]mvn -e install war#58;exploded jahia
  • Re: Jahia 6 - Templates Deployment
    2011/06/07 19:55

    Alexis_ Hi,<br/><br/>I have another problem !<br/>When i tried to execute :<br/>[code:8r96xgc6]mvn -e install war#58;exploded jahia

  • Number of messages  4
    Registration date Jun 7, 2011
    0 (0 Good)
    0 (0 Bad)

    Re: Jahia 6 - Templates Deployment

    by  Alexis_ »  2011/06/07 19:55

    Ok. I found my solution.

    When i tried to deploy my template maven couldn't find properties to deploy... so i named a profile jahia-deploy in my settings.xml like this :
    [code:orps98mv]
    lt;profile
  • Re: Jahia 6 - Templates Deployment
    2011/06/07 19:55

    Alexis_ Ok. I found my solution.<br/><br/>When i tried to deploy my template maven couldn't find properties to deploy... so i named a profile jahia-deploy in my settings.xml like this :<br/>[code:orps98mv] <br/>lt;profile

  • Number of messages  4
    Registration date Jun 7, 2011
    0 (0 Good)
    0 (0 Bad)

    Re: Jahia 6 - Templates Deployment

    by  Alexis_ »  2011/06/07 19:55

    Hello,

    I have another problem. Maybe somebody can help me.

    Now I can deploy my template without error but when I restart jahia I've go this error :

    2009-04-23 15:45:20,568: INFO [org.jahia.services.templates.JahiaTemplateManagerService] - Starting JahiaTemplateManagerService ...
    2009-04-23 15:45:20,569: INFO [org.jahia.services.templates.TemplatePackageDeployer] - Scanning templates directory...
    2009-04-23 15:45:21,821: INFO [org.jahia.services.content.automation.RulesListener] - Rules for webtemplates updated.
    2009-04-23 15:45:21,824: WARN [org.jahia.services.templates.TemplatePackageRegistry] - [b:14mgagru]Cannot parse definitions for Home Templates[/b:14mgagru]
    org.jahia.services.content.nodetypes.ParseException: [b:14mgagru]Missing = in namespace decl[/b:14mgagru]. (/usr/local/web/htdocs-v6/jahia-EAP/webapps/ROOT/templates/home-templates/definitions.cnd, line 3)
    at org.jahia.services.content.nodetypes.Lexer.fail(Lexer.java:199)
    at org.jahia.services.content.nodetypes.JahiaCndReader.doNameSpace(JahiaCndReader.java:211)
    at org.jahia.services.content.nodetypes.JahiaCndReader.parse(JahiaCndReader.java:172)
    at org.jahia.services.content.nodetypes.NodeTypeRegistry.addDefinitionsFile(NodeTypeRegistry.java:89)
    at org.jahia.services.templates.TemplatePackageRegistry.register(TemplatePackageRegistry.java:235)
    at org.jahia.services.templates.TemplatePackageDeployer.scanDeployedTemplatePackages(TemplatePackageDeployer.java:310)
    at org.jahia.services.templates.JahiaTemplateManagerService.start(JahiaTemplateManagerService.java:523)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

    My definitions.cnd is pretty simple :
    [code:14mgagru]
    // comment

    lt;home-templates = 'http
  • Re: Jahia 6 - Templates Deployment
    2011/06/07 19:55

    Alexis_ Hello,<br/><br/>I have another problem. Maybe somebody can help me.<br/><br/>Now I can deploy my template without error but when I restart jahia I've go this error :<br/><br/>2009-04-23 15:45:20,568: INFO [org.jahia.services.templates.JahiaTemplateManagerService] - Starting JahiaTemplateManagerService ...<br/>2009-04-23 15:45:20,569: INFO [org.jahia.services.templates.TemplatePackageDeployer] - Scanning templates directory...<br/>2009-04-23 15:45:21,821: INFO [org.jahia.services.content.automation.RulesListener] - Rules for webtemplates updated.<br/>2009-04-23 15:45:21,824: WARN [org.jahia.services.templates.TemplatePackageRegistry] - [b:14mgagru]Cannot parse definitions for Home Templates[/b:14mgagru]<br/>org.jahia.services.content.nodetypes.ParseException: [b:14mgagru]Missing = in namespace decl[/b:14mgagru]. (/usr/local/web/htdocs-v6/jahia-EAP/webapps/ROOT/templates/home-templates/definitions.cnd, line 3)<br/> at org.jahia.services.content.nodetypes.Lexer.fail(Lexer.java:199)<br/> at org.jahia.services.content.nodetypes.JahiaCndReader.doNameSpace(JahiaCndReader.java:211)<br/> at org.jahia.services.content.nodetypes.JahiaCndReader.parse(JahiaCndReader.java:172)<br/> at org.jahia.services.content.nodetypes.NodeTypeRegistry.addDefinitionsFile(NodeTypeRegistry.java:89)<br/> at org.jahia.services.templates.TemplatePackageRegistry.register(TemplatePackageRegistry.java:235)<br/> at org.jahia.services.templates.TemplatePackageDeployer.scanDeployedTemplatePackages(TemplatePackageDeployer.java:310)<br/> at org.jahia.services.templates.JahiaTemplateManagerService.start(JahiaTemplateManagerService.java:523)<br/> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)<br/> at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)<br/><br/>My definitions.cnd is pretty simple :<br/>[code:14mgagru]<br/>// comment<br/><br/>lt;home-templates = 'http

  • Number of messages  4
    Registration date Jun 7, 2011
    0 (0 Good)
    0 (0 Bad)

    Re: Jahia 6 - Templates Deployment

    by  pap@commaro.com »  2011/06/07 19:55

    Hi Alexis,

    try it with underscore:

    [code:2a232vdk]lt;home_templates = 'http

    Benjamin Papez (pap@commaro.com)

    Number of messages  220
    Registration date
    0 (0 Good)
    0 (0 Bad)

    Re: Jahia 6 - Templates Deployment

    by  pap@commaro.com »  2011/06/07 19:55

    Hi Charles,

    [quote=quot;cflond

    Benjamin Papez (pap@commaro.com)

    Number of messages  220
    Registration date
    0 (0 Good)
    0 (0 Bad)

    Re: Jahia 6 - Templates Deployment

    by  Alexis_ »  2011/06/07 19:55

    Thx Benjamin,

    I found it just before you gave me the soluce ! :)

    Thank you !

    Alexis
  • Re: Jahia 6 - Templates Deployment
    2011/06/07 19:55

    Alexis_ Thx Benjamin,<br/><br/>I found it just before you gave me the soluce ! <!-- s:) --><img src="{SMILIES_PATH}/icon_e_smile.gif" alt=":)" title="Smile" /><!-- s:) --> <br/><br/>Thank you !<br/><br/>Alexis

  • Number of messages  4
    Registration date Jun 7, 2011
    Contact
    Share
    Feedback

    Get in touch

    Whether you are a current user or if you are just evaluating Jahia, we are here to help.

    Contact us

    Share this page