Jahia Template Forum > deploy new template

0 (0 Good)
0 (0 Bad)

deploy new template

by  ahmad_j_alsaqa »  2011/06/07 20:06

Dears..
I got the following error when i tring install new template to jahia:
[INFO] Scanning for projects...
[INFO] Searching repository for plugin with prefix: 'war'.
[INFO] Searching repository for plugin with prefix: 'jahia'.
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] The plugin 'org.apache.maven.plugins:maven-jahia-plugin' does not exist o
r no valid version could be found
[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: lt 1 second
[INFO] Finished at: Tue Mar 09 12:17:21 GMT 02:00 2010
[INFO] Final Memory: 2M/5M
[INFO] ------------------------------------------------------------------------

?????? how can i solve it ?????

  (ahmad_j_alsaqa)

Number of messages  7
Registration date
0 (0 Good)
0 (0 Bad)

Re: deploy new template

by  pap@commaro.com »  2011/06/07 20:06

Hello,

which Jahia version are you using? Please confirm that it is a Jahia 6 version.

Did you follow this step: [url=http#58;//www

Benjamin Papez (pap@commaro.com)

Number of messages  220
Registration date
0 (0 Good)
0 (0 Bad)

Re: deploy new template

by  ahmad_j_alsaqa »  2011/06/07 20:06

hellow ..
i use jahia EE version 6.
i follow Environment and Tools Development documentation step by step to prepare the environment and create template.
best regards
saqqa

  (ahmad_j_alsaqa)

Number of messages  7
Registration date
0 (0 Good)
0 (0 Bad)

Re: deploy new template

by  ahmad_j_alsaqa »  2011/06/07 20:06

hellow ..
when i check again i found the path of my custom template is not valid template but when i fix the problem i got the following error.
tory central (http://repo1.maven.org/maven2)
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Failed to resolve artifact.

Missing:
----------
1) org.jahia.server:jahia-impl:jar:6.0

Try downloading the file manually from the project website.

Then, install it using the command:
mvn install:install-file -DgroupId=org.jahia.server -DartifactId=jahia-imp
l -Dversion=6.0 -Dpackaging=jar -Dfile=/path/to/file

Alternatively, if you host your own repository you can deploy the file there:

mvn deploy:deploy-file -DgroupId=org.jahia.server -DartifactId=jahia-impl
-Dversion=6.0 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[i
d]

Path to dependency:
1) org.jahia.templates:EraDataJahia:war:0.1
2) org.jahia.server:jahia-impl:jar:6.0

2) org.jahia.server:jahia-taglib:jar:6.0

Try downloading the file manually from the project website.

Then, install it using the command:
mvn install:install-file -DgroupId=org.jahia.server -DartifactId=jahia-tag
lib -Dversion=6.0 -Dpackaging=jar -Dfile=/path/to/file

Alternatively, if you host your own repository you can deploy the file there:

mvn deploy:deploy-file -DgroupId=org.jahia.server -DartifactId=jahia-tagli
b -Dversion=6.0 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=
[id]

Path to dependency:
1) org.jahia.templates:EraDataJahia:war:0.1
2) org.jahia.server:jahia-taglib:jar:6.0

----------
2 required artifacts are missing.

for artifact:
org.jahia.templates:EraDataJahia:war:0.1

from the specified remote repositories:
central (http://repo1.maven.org/maven2),
jahiaRepository (http://maven.jahia.org/maven2)

so i dont know how to install tehes artifacts???

  (ahmad_j_alsaqa)

Number of messages  7
Registration date
0 (0 Good)
0 (0 Bad)

Re: deploy new template

by  pap@commaro.com »  2011/06/07 20:06

Hello,

there is no version-id for the jahia artifacts called: 6.0

So far we only have:

6.0-CE for the 6.0 community edition
6.0.0-EA for the early adopters of the 6.0 enterprise edition
6.0.0-EE for the official 6.0 enterprise edition
6.0.1 for the 6.0 enterprise edition with service pack 1

When you created the project via archetype you should have entered the correct version-id. Now you can go and change it manually in the pom.xml of your template project. For instance if you use the 6.0.0-EE release, you need to find the lt;dependencies

Benjamin Papez (pap@commaro.com)

Number of messages  220
Registration date
Contact
Share
Feedback

Get in touch

Whether you are a current user or if you are just evaluating Jahia, we are here to help.

Contact us

Share this page