Jahia Dev Forum > template setup without...

0 (0 Good)
0 (0 Bad)

template setup without maven

by  testa »  2011/06/07 20:39

My earlier post disappeared so posting it again.

1. Please package templates in war file for download so that user can work on templates quickly and without spending hours messing with maven and reading documentation.

It's a big put off for users evaluating this product against other products.

2. files generated by jahia-templates-archetype is not valid. I get the following error when I deploy the template. I have not edited definitions.cnd file.
(C:\temp\jahia\jahia_v6_CommunityEdition_r25203\webapps\ROOT\jsp\jahia\templates\education1-templates\definitions.cnd, line 3)
org.jahia.services.content.nodetypes.ParseException: Missing ']' delimiter for end of node type name, found - (C:\temp\jahia\jahia_v6_CommunityEdition_r25203\webapps\ROOT\jsp\jahia\templates\education1-templates\definitions.cnd, line 3)
at org.jahia.services.content.nodetypes.Lexer.fail(Lexer.java:214)

3. I created a new virtual site with the newly installed template. When I view the virtual website, the gwt admin control does not show up. I see the homepage generated by the template. Is this normal?

Thanks
  • template setup without maven
    2011/06/07 20:39

    testa My earlier post disappeared so posting it again.<br/><br/>1. Please package templates in war file for download so that user can work on templates quickly and without spending hours messing with maven and reading documentation.<br/><br/>It's a big put off for users evaluating this product against other products.<br/><br/>2. files generated by jahia-templates-archetype is not valid. I get the following error when I deploy the template. I have not edited definitions.cnd file.<br/> (C:\temp\jahia\jahia_v6_CommunityEdition_r25203\webapps\ROOT\jsp\jahia\templates\education1-templates\definitions.cnd, line 3)<br/>org.jahia.services.content.nodetypes.ParseException: Missing ']' delimiter for end of node type name, found - (C:\temp\jahia\jahia_v6_CommunityEdition_r25203\webapps\ROOT\jsp\jahia\templates\education1-templates\definitions.cnd, line 3)<br/> at org.jahia.services.content.nodetypes.Lexer.fail(Lexer.java:214)<br/><br/>3. I created a new virtual site with the newly installed template. When I view the virtual website, the gwt admin control does not show up. I see the homepage generated by the template. Is this normal?<br/><br/>Thanks

  • Number of messages  12
    Registration date Jun 7, 2011
    0 (0 Good)
    0 (0 Bad)

    Re: template setup without maven

    by  pap@commaro.com »  2011/06/07 20:39

    Hello,

    thanks for your feedback.

    1. When you download Jahia, all available templates (ACME demo; test templates) are already part of the installation. You should find the template WAR files under lt;jahia-webapp

    Benjamin Papez (pap@commaro.com)

    Number of messages  220
    Registration date
    0 (0 Good)
    0 (0 Bad)

    Re: template setup without maven

    by  testa »  2011/06/07 20:39

    Thanks for the response.

    I did see the war file on that location, but I was looking for something lot simpler to play with.

    Here is my cnd file generated by maven.
    lt;education1_templates = 'http://education.com/jahia/education1-templates/nt/1.0'
  • Re: template setup without maven
    2011/06/07 20:39

    testa Thanks for the response.<br/><br/>I did see the war file on that location, but I was looking for something lot simpler to play with.<br/><br/>Here is my cnd file generated by maven.<br/>lt;education1_templates = 'http://education.com/jahia/education1-templates/nt/1.0'

  • Number of messages  12
    Registration date Jun 7, 2011
    0 (0 Good)
    0 (0 Bad)

    Re: template setup without maven

    by  pap@commaro.com »  2011/06/07 20:39

    Hello,

    thanks for the detailed answer.

    [quote=quot;testa

    Benjamin Papez (pap@commaro.com)

    Number of messages  220
    Registration date
    0 (0 Good)
    0 (0 Bad)

    Re: template setup without maven

    by  pap@commaro.com »  2011/06/07 20:39

    Hello,

    I have just updated the archetypes on our Maven server, so that the problems should be fixed with newly created projects. You should be able to use project names with dash and the home.jsp example is now using the template tags.

    Thank you for pointing at these issues.

    Regards,
    Benjamin

    Benjamin Papez (pap@commaro.com)

    Number of messages  220
    Registration date
    Contact
    Share
    Feedback

    Get in touch

    Whether you are a current user or if you are just evaluating Jahia, we are here to help.

    Contact us

    Share this page