Jahia Dev Forum > encoding portlet...

0 (0 Good)
0 (0 Bad)

encoding portlet UTF8

by  sani »  2011/06/07 20:45

I have a problem displaying Japanese characters in my protlet. I tested directly on the template, it works well but in the protlet not.

Thank you
  • encoding portlet UTF8
    2011/06/07 20:45

    sani I have a problem displaying Japanese characters in my protlet. I tested directly on the template, it works well but in the protlet not.<br/><br/>Thank you

  • Number of messages  9
    Registration date Jun 7, 2011
    0 (0 Good)
    0 (0 Bad)

    Re: encoding portlet UTF8

    by  shyrkov »  2011/06/07 20:45

    Hello,

    could you, please, provide a bit more information?
    1) Which response encoding is used by your portlet?
    2) Do you have any issues when you call the portlet Web application directly (outside the scope of Jahia)
    3) Which response encoding is configured in Jahia (WEB-INF/etc/config/jahia.properties)?

    Kind regards
    Sergiy
  • Re: encoding portlet UTF8
    2011/06/07 20:45

    shyrkov Hello,<br/><br/>could you, please, provide a bit more information?<br/>1) Which response encoding is used by your portlet?<br/>2) Do you have any issues when you call the portlet Web application directly (outside the scope of Jahia)<br/>3) Which response encoding is configured in Jahia (WEB-INF/etc/config/jahia.properties)?<br/><br/>Kind regards<br/>Sergiy

  • Number of messages  407
    Registration date Jun 7, 2011
    0 (0 Good)
    0 (0 Bad)

    Re: encoding portlet UTF8

    by  sani »  2011/06/07 20:45

    Thank you

    1) The encoding of the response used for the portlet is UTF8
    2) I have not tested the protlet Web directly without using the Jahia application.
    3) The encoding for jahia is UTF8

    Cordially
  • Re: encoding portlet UTF8
    2011/06/07 20:45

    sani Thank you<br/><br/>1) The encoding of the response used for the portlet is UTF8<br/>2) I have not tested the protlet Web directly without using the Jahia application.<br/>3) The encoding for jahia is UTF8 <br/><br/>Cordially

  • Number of messages  9
    Registration date Jun 7, 2011
    0 (0 Good)
    0 (0 Bad)

    Re: encoding portlet UTF8

    by  shyrkov »  2011/06/07 20:45

    Hello,

    please, ensure that your portlet is renderi8ng correct output and encoding is good, if you call it directly (directly call the portlet's WAR application).
    As it is hard to troubleshoot the problem without having the portlet, could you provide it, please?

    Kind regards
    Sergiy
  • Re: encoding portlet UTF8
    2011/06/07 20:45

    shyrkov Hello,<br/><br/>please, ensure that your portlet is renderi8ng correct output and encoding is good, if you call it directly (directly call the portlet's WAR application).<br/>As it is hard to troubleshoot the problem without having the portlet, could you provide it, please?<br/><br/>Kind regards<br/>Sergiy

  • Number of messages  407
    Registration date Jun 7, 2011
    0 (0 Good)
    0 (0 Bad)

    Re: encoding portlet UTF8

    by  sani »  2011/06/07 20:45

    Hello,

    I did a test. I added my portlet on the Jahia demo. I have the same problem.
    Please, can you take the test.

    Sincerely,
  • Re: encoding portlet UTF8
    2011/06/07 20:45

    sani Hello,<br/><br/>I did a test. I added my portlet on the Jahia demo. I have the same problem.<br/>Please, can you take the test.<br/><br/>Sincerely,

  • Number of messages  9
    Registration date Jun 7, 2011
    0 (0 Good)
    0 (0 Bad)

    Re: encoding portlet UTF8

    by  shyrkov »  2011/06/07 20:45

    Hello,

    could you, please, provide the portlet WAR file, you have used for your tests, and let me know the Jahia version build number you are using?

    Thank you in advance!

    Kind regards
    Sergiy
  • Re: encoding portlet UTF8
    2011/06/07 20:45

    shyrkov Hello,<br/><br/>could you, please, provide the portlet WAR file, you have used for your tests, and let me know the Jahia version build number you are using?<br/><br/>Thank you in advance!<br/><br/>Kind regards<br/>Sergiy

  • Number of messages  407
    Registration date Jun 7, 2011
    0 (0 Good)
    0 (0 Bad)

    Re: encoding portlet UTF8

    by  sani »  2011/06/07 20:45

    Hello,

    Jahia version build number: 31127 Jahia release, Professional Edition Build 31787


    The war is attached.

    The portlet displays character in Germany. it does not display correctly letter to Germany and also Japanese.

    Thank you very much for your help
  • Re: encoding portlet UTF8
    2011/06/07 20:45

    sani Hello,<br/><br/>Jahia version build number: 31127 Jahia release, Professional Edition Build 31787<br/><br/><br/>The war is attached.<br/><br/>The portlet displays character in Germany. it does not display correctly letter to Germany and also Japanese.<br/><br/>Thank you very much for your help

  • Number of messages  9
    Registration date Jun 7, 2011
    0 (0 Good)
    0 (0 Bad)

    Re: encoding portlet UTF8

    by  shyrkov »  2011/06/07 20:45

    Hello Nizar,

    I have taken Jahia 6.1.0 Professional Edition build 31787 and the portlet, you have attached (I had to correct web.xml a bit to be able to deploy it).

    Here is the screenshot for portlet rendering, I have:
    [img:x6mze4xw]http#58;//img88
  • Re: encoding portlet UTF8
    2011/06/07 20:45

    shyrkov Hello Nizar,<br/><br/>I have taken Jahia 6.1.0 Professional Edition build 31787 and the portlet, you have attached (I had to correct web.xml a bit to be able to deploy it).<br/><br/>Here is the screenshot for portlet rendering, I have:<br/>[img:x6mze4xw]http#58;//img88

  • Number of messages  407
    Registration date Jun 7, 2011
    0 (0 Good)
    0 (0 Bad)

    Re: encoding portlet UTF8

    by  sani »  2011/06/07 20:45

    Hello Sergiy,

    I still have the same problem.
    Here is a screenshot of protlet.

    Kind regards
    Nizar
  • Re: encoding portlet UTF8
    2011/06/07 20:45

    sani Hello Sergiy,<br/><br/>I still have the same problem.<br/>Here is a screenshot of protlet.<br/><br/>Kind regards<br/>Nizar

  • Number of messages  9
    Registration date Jun 7, 2011
    0 (0 Good)
    0 (0 Bad)

    Re: encoding portlet UTF8

    by  shyrkov »  2011/06/07 20:45

    Hello Nizar,

    than, I guess, this is related to the configuration of your Tomcat, if we get different results with the same use case.

    Could you, please, attach your:
    - <tomcat>/conf/server.xml
    - <tomcat>/conf/web.xml
    - <jahia-web-app-root>/WEB-INF/etc/config/jahia.properties
    ?

    Thank you in advance!

    Kind regards
    Sergiy

  • Re: encoding portlet UTF8
    2011/07/08 12:46

    shyrkov <p> Hello Nizar,<br /> <br /> than, I guess, this is related to the configuration of your Tomcat, if we get different results with the same use case.<br /> <br /> Could you, please, attach your:<br /> - &lt;tomcat&gt;/conf/server.xml<br /> - &lt;tomcat&gt;/conf/web.xml<br /> - &lt;jahia-web-app-root&gt;/WEB-INF/etc/config/jahia.properties<br /> ?<br /> <br /> Thank you in advance!<br /> <br /> Kind regards<br /> Sergiy</p>

  • Number of messages  407
    Registration date Jun 7, 2011
    Contact
    Share
    Feedback

    Get in touch

    Whether you are a current user or if you are just evaluating Jahia, we are here to help.

    Contact us

    Share this page