Jahia Dev Forum > Build from sources...

0 (0 Good)
0 (0 Bad)

Build from sources failed (Failure while parsing XML)

by  tyurk »  2011/06/07 20:39

Hello,

I am attempting to build Jahia from sources in order to get started on development, but have no prior experience with Maven. I have managed to overcome previous issues related to heap space and whatnot despite some strange environment-variable-ignoring behaviour on mvn's part, but this one has me stumped and I haven't found anything meaningful googling about.

Build fails with error below (partial log attached):
[INFO] [ERROR] Line 23: Unexpected element 'define-configuration-property'
[INFO] [ERROR] Failure while parsing XML

I am building on MacOSX 10.6.2, Maven 2.2.1, Java (Apple) 1.6.0_17, GWT 1.5.3 (tried with 1.7.1 to rule out the quot;unsupported on OSX 10.6

  (tyurk)

Number of messages  38
Registration date
0 (0 Good)
0 (0 Bad)

Re: Build from sources failed (Failure while parsing XML)

by  pap@commaro.com »  2011/06/07 20:39

Hello,

did you set the GWT profile under lt;profile

Benjamin Papez (pap@commaro.com)

Number of messages  220
Registration date
0 (0 Good)
0 (0 Bad)

Re: Build from sources failed (Failure while parsing XML)

by  tyurk »  2011/06/07 20:39

Good morning,
Looks like the forums don't accept txt files so I hadn't actually attached my log, but here it is.

Also, to answer the question, yes I did set the gwt-1.5.3 profile in settings.xml, which I have equally joined for your consultation in case I messed something up in there ;). It seems to be used by maven as expected as you can see from the first few lines in the log file. I'm not convinced the extrajvmargs are being passed into the gwt compiler, so this may be a source of problems. However, I tried hardcoding the headless arg into the mvn script to no avail.

Cheers,
Denis

[attachment=1:1m6v3j9x]maven-log.zip[/attachment:1m6v3j9x]
[attachment=0:1m6v3j9x]settings.zip[/attachment:1m6v3j9x]

  (tyurk)

Number of messages  38
Registration date
0 (0 Good)
0 (0 Bad)

Re: Build from sources failed (Failure while parsing XML)

by  pap@commaro.com »  2011/06/07 20:39

Hello,

thanks for the logs. They make things clear. The problem is that you have checked out the source from the trunk, which creates the 6.5-SNAPSHOT release of Jahia, which is the current development and an unstable version. It is already based on GWT 2.0 and to create this release you actually have to remove ANY gwt profiles from settings.xml, because Maven will download everything automatically.

So if you want to develop on a stable version, you need to check out this SVN branch: http://subversion.jahia.org/svn/jahia/b ... ITY-BRANCH

The available documentation on Jahiapedia describes working with this release. For that one you need to set the GWT profiles, like you already did.

Take the trunk currently only to see in which direction the development is going, but not yet for serious projects.

Regards,
Benjamin

Benjamin Papez (pap@commaro.com)

Number of messages  220
Registration date
0 (0 Good)
0 (0 Bad)

Re: Build from sources failed (Failure while parsing XML)

by  tyurk »  2011/06/07 20:39

Benjamin,
Thanks a bunch.

By the way, the link to the quot;Configure the Jahia Development Plugin

  (tyurk)

Number of messages  38
Registration date
0 (0 Good)
0 (0 Bad)

Re: Build from sources failed (Failure while parsing XML)

by  pap@commaro.com »  2011/06/07 20:39

Hello,

you're welcome. I also saw the broken links today. Will forward the message to the one taking care of these pages.

Regards,
Benjamin

Benjamin Papez (pap@commaro.com)

Number of messages  220
Registration date
0 (0 Good)
0 (0 Bad)

Re: Build from sources failed (Failure while parsing XML)

by  tyurk »  2011/06/07 20:39

Hi again,
So here's the irony: I managed to build the trunk version by removing the gwt profile from settings.xml and downloading gwt v2. However, the 6.0 stable community version refused to even start compilation, complaining of

[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] The plugin 'org.apache.maven.plugins:maven-jahia-plugin' does not exist or no valid version could be found

Any ideas? I figure I'm overlooking something in settings.xml, but really not sure...

Thanks again,

Denis

  (tyurk)

Number of messages  38
Registration date
0 (0 Good)
0 (0 Bad)

Re: Build from sources failed (Failure while parsing XML)

by  pap@commaro.com »  2011/06/07 20:39

Hello Denis,

do you get more infos before [ERROR] BUILD ERROR ? Normally the same Maven Jahia plugin version should be able to build both releases.

Could you also again attach the recent settings.xml ?

Regards,
Benjamin

Benjamin Papez (pap@commaro.com)

Number of messages  220
Registration date
0 (0 Good)
0 (0 Bad)

Re: Build from sources failed (Failure while parsing XML)

by  tyurk »  2011/06/07 20:39

Hello Benjamin,
There actually isn't a whole lot else. Running maven with -e yields the contents of log.txt. Both log.txt and settings.xml as used are zipped in docs.zip, joined below.

Thanks again for your help.

[attachment=0:2y93ibro]docs.zip[/attachment:2y93ibro]

Cheers,

Denis

  (tyurk)

Number of messages  38
Registration date
0 (0 Good)
0 (0 Bad)

Re: Build from sources failed (Failure while parsing XML)

by  pap@commaro.com »  2011/06/07 20:39

Hello,

strange, because it is looking for the plugin with the wrong package name, although you have the lt;pluginGroup

Benjamin Papez (pap@commaro.com)

Number of messages  220
Registration date
Contact
Share
Feedback

Get in touch

Whether you are a current user or if you are just evaluating Jahia, we are here to help.

Contact us

Share this page