Jahia in English > Problem's with Jahia...

0 (0 Good)
0 (0 Bad)

Problem's with Jahia 7 migration (modules)

by  akharii »  2014/05/20 08:38

 hi,

firstly I did the Jahia migration on a test server (with windows) and the migration gone fine.

But now, I'm making this migration on a Linux server and I have 2 problem's who concern the module


First when I upload my module in Edit mode I don't see the button 'Go to Studio' (whereas on windows after update and start module this button appear)

then when I would like to create a new module I have an error message like this :

And if you need more informations, this is my info-version of maven : 

 

 

Best regards,

Anthony

 

  • Problem's with Jahia 7 migration (modules)
    2014/05/20 08:51

    akharii <p> <span style="font-family: arial, sans-serif; font-size: 13px;">&nbsp;hi,</span><br style="font-family: arial, sans-serif; font-size: 13px;" /> <br style="font-family: arial, sans-serif; font-size: 13px;" /> <span style="font-family: arial, sans-serif; font-size: 13px;">firstly I did the Jahia migration on a test server (with windows) and the migration gone fine.</span><br style="font-family: arial, sans-serif; font-size: 13px;" /> <br style="font-family: arial, sans-serif; font-size: 13px;" /> <span style="font-family: arial, sans-serif; font-size: 13px;">But now, I&#39;m making this migration on a Linux server and I have 2 problem&#39;s who concern the module</span><br style="font-family: arial, sans-serif; font-size: 13px;" /> <br style="font-family: arial, sans-serif; font-size: 13px;" /> <br style="font-family: arial, sans-serif; font-size: 13px;" /> <span style="font-family: arial, sans-serif; font-size: 13px;">First when I upload my module in Edit mode I don&#39;t see the button &#39;Go to Studio&#39; (whereas on windows after update and start module this button appear)</span><br style="font-family: arial, sans-serif; font-size: 13px;" /> <br style="font-family: arial, sans-serif; font-size: 13px;" /> <span style="font-family: arial, sans-serif; font-size: 13px;">then when I would like to create a new module I have an error message like this :</span></p> <p> <img alt="" src="http://img4.hostingpics.net/pics/195109thePB.png" /></p> <p> <span style="font-family: arial, sans-serif; font-size: 13px;">And if you need more informations, this is my info-version of maven :&nbsp;</span></p> <p> &nbsp;</p> <p> <img alt="" src="http://img4.hostingpics.net/pics/788120laversion.png" /></p> <p> &nbsp;</p> <p> <span style="color: rgb(85, 85, 85); font-family: Arial, 'Helvetica Neue', Helvetica, sans-serif; font-size: 14px; line-height: 20px;">Best regards,</span></p> <p> Anthony</p> <p> &nbsp;</p>

  • Number of messages  9
    Registration date May 20, 2014
    0 (0 Good)
    3 (3 Bad)

    mhhh

    by  Anal-resistor »  2014/05/20 08:42

    Maybe you should find the answer in the Force ?

    Anal-resistor
    Number of messages  1
    Not registered
    0 (0 Good)
    0 (0 Bad)

    Re : Problem's with Jahia 7 migration (modules)

    by  glucazeau »  2014/05/20 08:46

    Hello Anthony,

    to create modules for Jahia (in the Studio or directly using the command line) you will need Maven 3.0.5.

    Please try again with this version and let me know if it fixes your problem.

    Regards,

    Guillaume

  • Re : Problem's with Jahia 7 migration (modules)
    2014/05/20 08:46

    glucazeau <p> Hello Anthony,</p> <p> to create modules for Jahia (in the Studio or directly using the command line) you will need Maven 3.0.5.</p> <p> Please try again with this version and let me know if it fixes your problem.</p> <p> Regards,</p> <p> Guillaume</p>

  • Number of messages  93
    Registration date May 20, 2014
    0 (0 Good)
    0 (0 Bad)

    Re : Re : Problem's with Jahia 7 migration (modules)

    by  akharii »  2014/05/20 08:53

    Hello Anthony,

    to create modules for Jahia (in the Studio or directly using the command line) you will need Maven 3.0.5.

    Please try again with this version and let me know if it fixes your problem.

    Regards,

    Guillaume


    Thanks Guillaume I will try it and I keep you informed.

  • Re : Re : Problem's with Jahia 7 migration (modules)
    2014/05/20 08:53

    akharii <blockquote> <p> Hello Anthony,</p> <p> to create modules for Jahia (in the Studio or directly using the command line) you will need Maven 3.0.5.</p> <p> Please try again with this version and let me know if it fixes your problem.</p> <p> Regards,</p> <p> Guillaume</p> </blockquote> <br /> <p> Thanks Guillaume I will try it and I keep you informed.</p>

  • Number of messages  9
    Registration date May 20, 2014
    0 (0 Good)
    0 (0 Bad)

    Re : Re : Re : Problem's with Jahia 7 migration (modules)

    by  akharii »  2014/05/20 14:27

    I have corrected  the problem with Maven and now i have a newest error message :

     

    Failed to execute goal on project social: Could not resolve dependencies for project org.jahia.modules:social:bundle:1.0-SNAPSHOT: The following artifacts could not be resolved: org.jbpm:jbpm-human-task-core:jar:nocdi:6.0.0.Final-jahia, org.jbpm:jbpm-human-task-audit:jar:nocdi:6.0.0.Final, org.jbpm:jbpm-human-task-workitems:jar:nocdi:6.0.0.Final, org.jbpm:jbpm-audit:jar:6.0.0.Final-jahia, org.jbpm:jbpm-runtime-manager:jar:nocdi:6.0.0.Final: Could not transfer artifact org.jbpm:jbpm-human-task-core:jar:nocdi:6.0.0.Final-jahia from/to jahia-public (https://devtools.jahia.com/nexus/content/groups/public): Read timed out

  • Re : Re : Re : Problem's with Jahia 7 migration (modules)
    2014/05/20 14:27

    akharii <p> I have corrected &nbsp;the problem with Maven and now i have a newest error message :</p> <p> &nbsp;</p> <blockquote> <p> Failed to execute goal on project social: Could not resolve dependencies for project org.jahia.modules:social:bundle:1.0-SNAPSHOT: The following artifacts could not be resolved: org.jbpm:jbpm-human-task-core:jar:nocdi:6.0.0.Final-jahia, org.jbpm:jbpm-human-task-audit:jar:nocdi:6.0.0.Final, org.jbpm:jbpm-human-task-workitems:jar:nocdi:6.0.0.Final, org.jbpm:jbpm-audit:jar:6.0.0.Final-jahia, org.jbpm:jbpm-runtime-manager:jar:nocdi:6.0.0.Final: Could not transfer artifact org.jbpm:jbpm-human-task-core:jar:nocdi:6.0.0.Final-jahia from/to jahia-public (https://devtools.jahia.com/nexus/content/groups/public): Read timed out</p> </blockquote>

  • Number of messages  9
    Registration date May 20, 2014
    0 (0 Good)
    0 (0 Bad)

    Re : Re : Re : Re : Problem's with Jahia 7 migration (modules)

    by  glucazeau »  2014/05/20 14:51

    You get this error when creating a new module? Or trying to build an existing one? If so, could you please this module's pom.xml with us?

    If you're trying to migrate a 6.6 module to a 7.0 module, you have a Maven goal available in the Maven Jahia plugin: mvn

    org.jahia.server:jahia-maven-plugin:4.0:convert-to-osgi

  • Re : Re : Re : Re : Problem's with Jahia 7 migration (modules)
    2014/05/20 14:51

    glucazeau <p> You get this error when creating a new module? Or trying to build an existing one? If so, could you please this module&#39;s pom.xml with us?</p> <p> If you&#39;re trying to migrate a 6.6 module to a 7.0 module, you have a Maven goal available in the Maven Jahia plugin: mvn</p> <p> org.jahia.server:jahia-maven-plugin:4.0:convert-to-osgi</p>

  • Number of messages  93
    Registration date May 20, 2014
    0 (0 Good)
    0 (0 Bad)

    Re : Re : Re : Re : Re : Problem's with Jahia 7 migration (modules)

    by  akharii »  2014/05/20 15:19

    You get this error when creating a new module? Or trying to build an existing one? If so, could you please this module's pom.xml with us?

    If you're trying to migrate a 6.6 module to a 7.0 module, you have a Maven goal available in the Maven Jahia plugin: mvn

    org.jahia.server:jahia-maven-plugin:4.0:convert-to-osgi


    Yes, i have this error when i create a new module.

    And my module are in 7.0 (i upgrade all of my module during the test phase on windows os)

     

  • Re : Re : Re : Re : Re : Problem's with Jahia 7 migration (modules)
    2014/05/21 14:40

    akharii <blockquote> <p> You get this error when creating a new module? Or trying to build an existing one? If so, could you please this module&#39;s pom.xml with us?</p> <p> If you&#39;re trying to migrate a 6.6 module to a 7.0 module, you have a Maven goal available in the Maven Jahia plugin: mvn</p> <p> org.jahia.server:jahia-maven-plugin:4.0:convert-to-osgi</p> </blockquote> <br /> <p> Yes, i have this error when i create a new module.</p> <p> And my module are in 7.0 (i upgrade all of my module during the test phase on windows os)</p> <p> &nbsp;</p>

  • Number of messages  9
    Registration date May 20, 2014
    0 (0 Good)
    0 (0 Bad)

    Re : Re : Re : Re : Re : Re : Problem's with Jahia 7 migration (modules)

    by  akharii »  2014/05/21 14:45

    So, now i can't start the server and i don't find the problem.

    my java version is :

    java version "1.7.0_55"
    OpenJDK Runtime Environment (IcedTea 2.4.7) (7u55-2.4.7-1ubuntu1~0.12.04.2)
    OpenJDK 64-Bit Server VM (build 24.51-b03, mixed mode)
    my maven version is : 
     
    Apache Maven 3.0.4
    Maven home: /usr/share/maven

    Edit 1 : I have resolved this problem. my Inde are corompt after a server crash so i make an re-indexing

    But i always have my problem with the creation of modul in jahia

        edit 2 : i have corrected the problem's with the module creation (after reindexing i have already a 'social' folder so i delete it and it's good.But it's always impossible to see my module (module who are upload in admin mode) in studio, in fact the button 'Go to Studio don't appear.

    On windows button are here :

     

    But he's not on linux, and when i clik on 'Download sources' i have the authentification problem like edit 3.

     

     

     

     

     

     

     

    Edit3: Module who are upload from a windows folder d'ont appear on my Studio.

    So i have install subversion on my linux and i try to retrieve my module with "get modul from sources' but i have a problem for authentification

     authorization failed: Could not authenticate to server: rejected Basic challenge 

    The error message in Jahia Studio :

     

    The solution be coming,  i have a positive mindset .

  • Re : Re : Re : Re : Re : Re : Problem's with Jahia 7 migration (modules)
    2014/05/22 13:16

    akharii <blockquote> <p> <em>So, now i can&#39;t start the server and i don&#39;t find the problem.</em></p> <p> <em>my java version is :</em></p> <div> <em>java version &quot;1.7.0_55&quot;</em></div> <div> <em>OpenJDK Runtime Environment (IcedTea 2.4.7) (7u55-2.4.7-1ubuntu1~0.12.04.2)</em></div> <div> <em>OpenJDK 64-Bit Server VM (build 24.51-b03, mixed mode)</em></div> <div> <em>my maven version is :&nbsp;</em></div> <div> &nbsp;</div> <div> <blockquote> <div> <em>Apache Maven 3.0.4</em></div> <div> <em>Maven home: /usr/share/maven</em></div> </blockquote> </div> </blockquote> <p> <strong><span style="color:#ff0000;">Edit 1&nbsp;</span></strong>: I have resolved this problem. my Inde are corompt after a server crash so i make an re-indexing</p> <p> But i always have my problem with the creation of modul in jahia</p> <p> &nbsp; &nbsp; <strong><span style="color:#ff0000;">edit 2 :</span></strong> i have corrected the problem&#39;s with the module creation (after reindexing i have already a &#39;social&#39; folder so i delete it and it&#39;s good.But it&#39;s always<span style="background-color:#ffff00;"> impossible to see my module (module who are upload in admin mode) in studio, in fact the button &#39;Go to Studio don&#39;t appear</span>.</p> <p> On windows button are here :</p> <p> <img alt="" src="http://img4.hostingpics.net/pics/617825onwindows.png" /></p> <p> &nbsp;</p> <p> But he&#39;s not on linux, and when i clik on &#39;Download sources&#39; i have the authentification problem like edit 3.</p> <p> <img alt="" src="http://img4.hostingpics.net/pics/903291onlinux.png" style="width: 863px; height: 196px; float: left;" /></p> <p> &nbsp;</p> <p> &nbsp;</p> <p> &nbsp;</p> <p> &nbsp;</p> <p> &nbsp;</p> <p> &nbsp;</p> <p> &nbsp;</p> <p> <span style="color:#ff0000;"><strong>Edit3:</strong></span>&nbsp;<span style="color: rgb(85, 85, 85); font-family: Arial, 'Helvetica Neue', Helvetica, sans-serif; font-size: 14px; line-height: 20px;">Module who are upload from a windows folder d&#39;ont appear on my Studio.</span></p> <p style="margin: 0px 0px 10px; color: rgb(85, 85, 85); font-family: Arial, 'Helvetica Neue', Helvetica, sans-serif; font-size: 14px; line-height: 20px;"> So i have install subversion on my linux and i try to retrieve my module with &quot;get modul from sources&#39; but i have a problem for authentification</p> <blockquote style="padding: 0px 0px 0px 15px; margin: 0px 0px 20px; border-left-width: 5px; border-left-style: solid; border-left-color: rgb(51, 153, 255); color: rgb(85, 85, 85); font-family: Arial, 'Helvetica Neue', Helvetica, sans-serif; font-size: 14px; line-height: 20px;"> <p style="margin: 0px 0px 15px;"> <span style="background-color: rgb(255, 255, 0);">&nbsp;authorization failed: Could not authenticate to server: rejected Basic challenge&nbsp;</span></p> </blockquote> <p style="margin: 0px 0px 10px; color: rgb(85, 85, 85); font-family: Arial, 'Helvetica Neue', Helvetica, sans-serif; font-size: 14px; line-height: 20px;"> The error message in Jahia Studio :</p> <p style="margin: 0px 0px 10px; color: rgb(85, 85, 85); font-family: Arial, 'Helvetica Neue', Helvetica, sans-serif; font-size: 14px; line-height: 20px;"> <img alt="" src="http://img4.hostingpics.net/pics/261166svnauth.png" style="width: 298px; height: 196px;" /></p> <p style="margin: 0px 0px 10px; color: rgb(85, 85, 85); font-family: Arial, 'Helvetica Neue', Helvetica, sans-serif; font-size: 14px; line-height: 20px;"> &nbsp;</p> <p style="margin: 0px 0px 10px; color: rgb(85, 85, 85); font-family: Arial, 'Helvetica Neue', Helvetica, sans-serif; font-size: 14px; line-height: 20px;"> The solution be coming,&nbsp;<font color="#242424" face="Arial, sans-serif"><span style="line-height: 18px;">&nbsp;i have a positive mindset .</span></font></p>

  • Number of messages  9
    Registration date May 21, 2014
    0 (0 Good)
    0 (0 Bad)

    Re: Re : Re : Re : Re : Re : Re : Problem's with Jahia 7 migration (modules)

    by  glucazeau »  2014/05/22 13:09

    Hello Anthony,

    I'll try to look at this missing "Got to studio" button issue but there is no reason for me that it would work on Windows and not on Linux.

    Are you able to checkout a module with Subversion using the command line? Because Jahia will use these credentials to perform SVN actions, so you might have to initialize them first.

    Regards,

    Guillaume

    glucazeau
    Number of messages  1
    Not registered
    0 (0 Good)
    0 (0 Bad)

    Re : Re: Re : Re : Re : Re : Re : Re : Problem's with Jahia 7 migration (modules)

    by  akharii »  2014/05/22 14:12

    hi Guillaume and many thanks for your interest.

     

    Are you able to checkout a module with Subversion using the command line? 

     

    yes it's done and i have the same error windows when i trying to get module from source or when I click on 'download sources'

  • Re : Re: Re : Re : Re : Re : Re : Re : Problem's with Jahia 7 migration (modules)
    2014/05/22 14:12

    akharii <p> hi Guillaume and many thanks for your interest.</p> <p> &nbsp;</p> <blockquote> <p> Are you able to checkout a module with Subversion using the command line?&nbsp;</p> </blockquote> <p> &nbsp;</p> <p> yes it&#39;s done and i have the same error windows when i trying to get module from source or when I click on &#39;download sources&#39;</p> <p> <img alt="" src="http://img4.hostingpics.net/pics/261166svnauth.png" style="width: 298px; height: 196px;" /></p>

  • Number of messages  9
    Registration date May 22, 2014
    Contact
    Share
    Feedback

    Get in touch

    Whether you are a current user or if you are just evaluating Jahia, we are here to help.

    Contact us

    Share this page