Jahia in English > Is there a way to...

0 (0 Good)
0 (0 Bad)

Is there a way to tell why a templateSet isn't being recognized by jahia?

by  dipejipufi@1thecity.biz »  2018/10/30 21:28

I have been asked to extend a template set. I packaged the source into an osgi module with 'mvn clean install', then moved it to 'digital-factory-data/sources'.  I did the same with all the other packages that the template set depends on.  But when I look in the dropdown of available template sets, it isn't there.

How do i troubleshoot this?

  • Is there a way to tell why a templateSet isn't being recognized by jahia?
    2018/10/30 21:28

    dipejipufi@1thecity.biz <p>I have been asked to extend a template set. I packaged the source into an osgi module with &#39;mvn clean install&#39;, then moved it to &#39;digital-factory-data/sources&#39;.&nbsp; I did the same with all the other packages that the template set depends on.&nbsp; But when I look in the dropdown of available template sets, it isn&#39;t there.</p> <p>How do i troubleshoot this?</p>

  • Number of messages  1
    Registration date Oct 30, 2018
    0 (0 Good)
    0 (0 Bad)

    Re: Is there a way to tell why a templateSet isn't being recognized by jahia?

    by  ccheriyan@jahia.com »  2018/10/30 23:35

    Hi,

    To have the template set available for your websites, you can upload the jar from admin UI. Also, once you start the module, Jahia should pick up the sources and you should be able to access the modules in Studio.

      (ccheriyan@jahia.com)

    Number of messages  6
    Registration date
    0 (0 Good)
    0 (0 Bad)

    Re: Is there a way to tell why a templateSet isn't being recognized by jahia?

    by  langaleriee@gmail.com »  2018/11/09 14:10

    First of all, are you working with the studio, with eclipse ?

    If you have compiled with a mvn clean install, copy paste your jar on : Jahia\digital-factory-data\modules\

    Then, be sure to have a proper configuration of the repository.xml file located in your package at your-templates\src\main\import\repository.xml

  • Re: Is there a way to tell why a templateSet isn't being recognized by jahia?
    2018/11/09 14:10

    langaleriee@gmail.com <p>First of all, are you working with the studio, with eclipse ?</p> <p>If you have compiled with a mvn clean install, copy paste your jar on : Jahia\digital-factory-data\modules\</p> <p>Then, be sure to have a proper configuration of the repository.xml file located in your package at&nbsp;your-templates\src\main\import\repository.xml</p>

  • Number of messages  5
    Registration date Nov 9, 2018
    Contact
    Share
    Feedback

    Get in touch

    Whether you are a current user or if you are just evaluating Jahia, we are here to help.

    Contact us

    Share this page