Jahia in English > Intellij Idea -...

0 (0 Good)
0 (0 Bad)

Intellij Idea - Maven Build Project Error

by  santa.krishnan@borngroup.com »  2018/03/28 19:29

Hi Team

I am a novice developer to Jahia development, as part of Basic developer training I created a Component using Studio and then from Resource folder I imported the Acme Maven project into my IntelliJ Idea (2017.3.5) version with Maven and JDK are all mapped.

When I Tried to hit Build -> Build Project, I am getting following error message ( I am running on a Mac Machine)

Error:osgi: [acmecompany] The Provide-Capability with namespace ${jahia.plugin.providedNodeTypes} is not a symbolic name
Error:osgi: [acmecompany] The Require-Capability with namespace ${jahia.plugin.requiredNodeTypes} is not a symbolic name

Note: The same Project I tried running through Terminal  ( I created a profile in maven settings.xml)

mvn clean install jahia:deploy -P jahia-7.0-tomcat

  (santa.krishnan@borngroup.com)

Number of messages  1
Registration date
0 (0 Good)
0 (0 Bad)

Re: Intellij Idea - Maven Build Project Error

by  cefou »  2018/04/12 15:06

Hi Santa,

A Jahia Maven module doesn't compile through the Intellij ' Build -> Build Project' menu.

You should try to create an Intellij run configuration for a Maven project, following theses steps:

https://www.jetbrains.com/help/idea/run-debug-configuration-maven.html

with:
Name = "JahiaDeploy"
Working directory= choose the path to the pom.xml of your Jahia module/project
Command line: clean install jahia:deploy
Profiles: jahia-7.0-tomcat

 

Then go to "Run > Run... > JahiaDeploy" Intellij menu and it will build your Jahia module.

Rem: if your project doesn't build with your command line "mvn clean install jahia:deploy -P jahia-7.0-tomcat", then try this documentation first:
https://academy.jahia.com/documentation/digital-experience-manager/7.2/development/osgi-module-development/deploying-an-osgi-module

Kind regards,

  (cefou)

Number of messages  17
Registration date
Contact
Share
Feedback

Get in touch

Whether you are a current user or if you are just evaluating Jahia, we are here to help.

Contact us

Share this page