Jahia in English > getting error while...

0 (0 Good)
0 (0 Bad)

getting error while building Jahia template

by  prinitha »  2011/06/07 18:46

Hello
I am new to Jahia environment..I am trying develop one simple Jahia application.
After creating the template project when I try to deploy the project I am getting the following error.

[b:27xusms7]'The plugin 'org.apache.maven.plugins:maven-jahia-plugin' does not exist or no valid version could be found'
[/b:27xusms7]

How do i get rid of this error???

Thanks in advance

  (prinitha)

Number of messages  3
Registration date
0 (0 Good)
0 (0 Bad)

Re: getting error while building Jahia template

by  pap@commaro.com »  2011/06/07 18:46

Hello,

the problem is that in your case Maven searches the Jahia plugin with the wrong package name. This error was already once discussed in this forum - if you use the Jahia 6.0 CE edition then see here for a possible solution: [url:1jwpdzcp]http/1t=273[/url:1jwpdzcp]

If it does not help, please tell us which Jahia version you use and also attach your settings.xml

Regards,
Benjamin

Benjamin Papez (pap@commaro.com)

Number of messages  220
Registration date
0 (0 Good)
0 (0 Bad)

Re: getting error while building Jahia template

by  prinitha »  2011/06/07 18:46

Thank you for your reply now that problem got solved.
Now I am getting
/1.
I have define GWT in settings.xml properties and in environment variable but still I am getting this error?
Could you please tell me what do to?

  (prinitha)

Number of messages  3
Registration date
0 (0 Good)
0 (0 Bad)

Re: getting error while building Jahia template

by  pap@commaro.com »  2011/06/07 18:46

Hello,

great to see, that we are making progress. Can you please tell me, which Jahia release you use and which GWT release you have downloaded ? What did you set for google.webtoolkit.home and did you set the gwt profile under the /1 section ?

Regards,
Benjamin

Benjamin Papez (pap@commaro.com)

Number of messages  220
Registration date
0 (0 Good)
0 (0 Bad)

Re: getting error while building Jahia template

by  prinitha »  2011/06/07 18:46

Hello

I am using JAHIA 6 community edition and Google webtoolkit 'gwt-2.0.4'.

I have described the GWT home and active profile in the following manner

/1

Is it correct?

Thanks in advance

  (prinitha)

Number of messages  3
Registration date
0 (0 Good)
0 (0 Bad)

Re: getting error while building Jahia template

by  pap@commaro.com »  2011/06/07 18:46

Hello,

the Jahia 6.0 CE has a dependency to GWT 1.5.3 . You can not use it with the latest GWT release. Please download and install the GWT 1.5.3 version from here: [url:3bqbkyvt]http/1html[/url:3bqbkyvt] and configure that in the settings.xml .

Regards,
Benjamin

Benjamin Papez (pap@commaro.com)

Number of messages  220
Registration date
Contact
Share
Feedback

Get in touch

Whether you are a current user or if you are just evaluating Jahia, we are here to help.

Contact us

Share this page