Jahia in English > Different content...

0 (0 Good)
0 (0 Bad)

Different content in Preview and Live~

by  singhvik »  2012/01/03 13:41

Hi

 

I have created a module in Jahia using JSPs in the modules that get data from a custom Database (outside jahia). While it is getting the data and displaying properly, for the last couple of days, its not picking up latest data from database and instead seems to be showing old value (cached?). When I look at the same page in preview mode, it shows the latest data from database  but the live mode is still stuck at old data. I have tried flush all caches, re-published and re-started the server but it still remains that same.

Has anyone else faced this issue or am I missing something here? I am usinhg Jahia 6.5

 

Thanks!

 

  • Different content in Preview and Live~
    2012/01/03 13:41

    singhvik <p> Hi</p> <p> &nbsp;</p> <p> I have created a module in Jahia using JSPs in the modules that get data from a custom Database (outside jahia). While it is getting the data and displaying properly, for the last couple of days, its not picking up latest data from database and instead seems to be showing old value (cached?). When I look at the same page in preview mode, it shows the latest data from database &nbsp;but the live mode is still stuck at old data. I have tried flush all caches, re-published and re-started the server but it still remains that same.</p> <p> Has anyone else faced this issue or am I missing something here? I am usinhg Jahia 6.5</p> <p> &nbsp;</p> <p> Thanks!</p> <p> &nbsp;</p>

  • Number of messages  3
    Registration date Jan 3, 2012
    0 (0 Good)
    0 (0 Bad)

    Re: Different content in Preview and Live~

    by  shyrkov »  2012/01/03 14:01

    Hello Tim,

    yes, the output in live mode is cached by default (see documentation).

    You can disable it programmatically for your template, by creating a property file with an entry

    cache.expiration = 0

    Or directly in edit mode, opening an edit engine on you components -> "Options" tab -> Cache -> Expiration (seconds): 0

    Kind regards
    Sergiy

  • Re: Different content in Preview and Live~
    2012/01/03 14:01

    shyrkov <p> Hello Tim,<br /> <br /> yes, the output in live mode is cached by default (see <a href="http://www.jahia.com/community/documentation/jahiapedia/cache/cache.html">documentation</a>).<br /> <br /> You can disable it programmatically for your template, by creating a property file with an entry<br /> <br /> cache.expiration = 0<br /> <br /> Or directly in edit mode, opening an edit engine on you components -&gt; &quot;Options&quot; tab -&gt; Cache -&gt; Expiration (seconds): 0<br /> <br /> Kind regards<br /> Sergiy</p>

  • Number of messages  407
    Registration date Jan 3, 2012
    0 (0 Good)
    0 (0 Bad)

    Re: Re: Different content in Preview and Live~

    by  singhvik »  2012/01/03 15:54

    Thanks Sergiy

    I've tried both methods mentioned as per your suggestion below and the documentation but its still the same. I have also flushed the cache from "Caches" option. I still see that updated data in preview mode and old data in Live.

    Some more details on the structure - The module that gets data from the database is in the template, so I went into the studio, right clicked on block in the template and set cache expiration to 0 in Options tab.

     

    Thanks

    T.H.

  • Re: Re: Different content in Preview and Live~
    2012/01/03 15:55

    singhvik <p> Thanks&nbsp;Sergiy</p> <p> I&#39;ve tried both methods mentioned as per your suggestion below and the documentation but its still the same. I have also flushed the cache from &quot;Caches&quot; option. I still see that updated data in preview mode and old data in Live.</p> <p> Some more details on the structure - The module that gets data from the database is in the template, so I went into the studio, right clicked on block in the template and set cache expiration to 0 in Options tab.</p> <p> &nbsp;</p> <p> Thanks</p> <p> T.H.</p>

  • Number of messages  3
    Registration date Jan 3, 2012
    0 (0 Good)
    0 (0 Bad)

    Re: Re: Re: Different content in Preview and Live~

    by  singhvik »  2012/01/03 18:05

    Issue Resolved - I completely disabled the HTML cache for now while we are testing the aplication.

  • Re: Re: Re: Different content in Preview and Live~
    2012/01/03 18:05

    singhvik <p> <strong>Issue Resolved - I&nbsp;</strong>completely disabled the HTML cache for now while we are testing the aplication.</p>

  • Number of messages  3
    Registration date Jan 3, 2012
    0 (0 Good)
    0 (0 Bad)

    Re: Re: Re: Different content in Preview and Live~

    by  abhinitb »  2013/04/22 07:00

    Hi Tim, 

    Did you redeploy the template set after setting the cache expiration to 0. 

    It should work after setting this attribute.

    Best Regards,

    Abhinit

  • Re: Re: Re: Different content in Preview and Live~
    2013/04/22 07:00

    abhinitb <p> Hi Tim,&nbsp;</p> <p> Did you redeploy the template set after setting the cache expiration to 0.&nbsp;</p> <p> It should work after setting this attribute.</p> <p> Best Regards,</p> <p> Abhinit</p>

  • Number of messages  28
    Registration date Apr 22, 2013
    Contact
    Share
    Feedback

    Get in touch

    Whether you are a current user or if you are just evaluating Jahia, we are here to help.

    Contact us

    Share this page