Jahia in English > Cannot add new module...

0 (0 Good)
0 (0 Bad)

Cannot add new module to site

by  casey.sybrandy@red-alpha.com »  2019/04/10 18:39

Hello,

I'm trying to create a simple little module just to get my feet wet.  All I've done so far is create a simple content moduel that has a title.  Everything looks fine, but when I add it to the demo site home page, it does have me fill in a title, but it never appears after the refresh.  I checked the logs and I don't see any errors.  Any idea as to what is going on?

Additional info:

  • Under module details, the module is active for the digitall site and the node type is considered a usable component.
  • Definition:

[jnt:testNode] > jnt:content, jmix:structuredContent
 - jcr:title (string)

  • JSP/View

<%@ page language="java" contentType="text/html;charset=UTF-8" %>
<%@ taglib prefix="template" uri="http://www.jahia.org/tags/templateLib" %>
<%@ taglib prefix="c" uri="http://java.sun.com/jsp/jstl/core" %>
<%@ taglib prefix="fn" uri="http://java.sun.com/jsp/jstl/functions" %>
<%@ taglib prefix="fmt" uri="http://java.sun.com/jsp/jstl/fmt" %>
<%@ taglib prefix="jcr" uri="http://www.jahia.org/tags/jcr" %>
<%@ taglib prefix="ui" uri="http://www.jahia.org/tags/uiComponentsLib" %>
<%@ taglib prefix="functions" uri="http://www.jahia.org/tags/functions" %>
<%@ taglib prefix="query" uri="http://www.jahia.org/tags/queryLib" %>
<%@ taglib prefix="utility" uri="http://www.jahia.org/tags/utilityLib" %>
<%@ taglib prefix="s" uri="http://www.jahia.org/tags/search" %>
<%--@elvariable id="currentNode" type="org.jahia.services.content.JCRNodeWrapper"--%>
<%--@elvariable id="out" type="java.io.PrintWriter"--%>
<%--@elvariable id="script" type="org.jahia.services.render.scripting.Script"--%>
<%--@elvariable id="scriptInfo" type="java.lang.String"--%>
<%--@elvariable id="workspace" type="java.lang.String"--%>
<%--@elvariable id="renderContext" type="org.jahia.services.render.RenderContext"--%>
<%--@elvariable id="currentResource" type="org.jahia.services.render.Resource"--%>
<%--@elvariable id="url" type="org.jahia.services.render.URLGenerator"--%>

<h1>${currentNode.properties['jcr:title'].string}</h1>

  (casey.sybrandy@red-alpha.com)

Number of messages  2
Registration date
0 (0 Good)
0 (0 Bad)

Re: Cannot add new module to site

by  ccheriyan@jahia.com »  2019/04/10 18:54

Hi, the definitions and views look fine. Have you redeployed the module and tried? And is it the same when you create a new content of type jnt:testNode?

  (ccheriyan@jahia.com)

Number of messages  6
Registration date
0 (0 Good)
0 (0 Bad)

It worked!

by  casey.sybrandy@red-alpha.com »  2019/04/11 15:35

Thanks.  I forgot to mention that I'm using the SDK, so I was under the impression that you didn't have to deploy the code manually.  I deployed and I saw an old one that I had created pop-up on the site.  Not sure if the fact I had to restart the server made it work or deploying (I forgot to confirm it still wasn't working).

  (casey.sybrandy@red-alpha.com)

Number of messages  2
Registration date
Contact
Share
Feedback

Get in touch

Whether you are a current user or if you are just evaluating Jahia, we are here to help.

Contact us

Share this page