Jahia in English > Archetype jahia-templatesSet-a...

0 (0 Good)
0 (0 Bad)

Archetype jahia-templatesSet-archetype not found

by  tlombard »  2015/03/03 10:40

Hello,

I downloaded Digital Factory 7.0.0.4, enterprise edition (SDK) and I am trying to create a website with it.

Creation and manipulation of a module inside the studio seems ok for me. However when I try to create a new templates set from the studio, it does not work, I have the following log :

[INFO] Using the builder org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder with a thread count of 1
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building Maven Stub Project (No POM) 1
[INFO] ------------------------------------------------------------------------
[INFO] 
[INFO] >>> maven-archetype-plugin:2.0-alpha-5:generate (default-cli) @ standalone-pom >>>
[INFO] 
[INFO] <<< maven-archetype-plugin:2.0-alpha-5:generate (default-cli) @ standalone-pom <<<
[INFO] 
[INFO] --- maven-archetype-plugin:2.0-alpha-5:generate (default-cli) @ standalone-pom ---
[INFO] Generating project in Batch mode
[WARNING] Specified archetype not found.
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 0.558 s
[INFO] Finished at: 2015-03-03T11:17:14+01:00
[INFO] Final Memory: 9M/244M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-archetype-plugin:2.0-alpha-5:generate (default-cli) on project standalone-pom: The desired archetype does not exist (org.jahia.archetypes:jahia-templatesSet-archetype:1.0) -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException

So apparently the archetype cannot be found. I seem to have jahia-templatesSet-archetype:2.2, but not the 1.0.

Has anyone already encountered this problem and know how to solve it ?

Thanks in advance.

Thomas

  (tlombard)

Number of messages  2
Registration date
0 (0 Good)
0 (0 Bad)

Re : Archetype jahia-templatesSet-archetype not found

by  tlombard »  2015/03/03 12:09

Hello me,

I don't know if that is the cause of the problem but I wonder if Jahia was installed correctly. It was installed in c:/javatools, contrary to what is said in the doc. When installing it to c:/, I can create a templates set just after.

So my problem seems to be solved. Thanks :)

Thomas

  (tlombard)

Number of messages  2
Registration date
Contact
Share
Feedback

Get in touch

Whether you are a current user or if you are just evaluating Jahia, we are here to help.

Contact us

Share this page